Cant connect my freedom jayb's to the mysound app, solutions?

Comments

14 comments

  • bbrac

    @David Gjerde 

    Please try the following to connect your Freedom's to the MySound app:

    1. Make sure your Freedom's have been paired to your listening device. This needs to be done through your devices Bluetooth Settings.

    2. Make sure your Freedom's are turned on.

    3. Open the MySound app and 'scanning' will appear at the bottom of the screen. If 'No headphones connected' is displayed, please wait and MySound will search again after about 10 seconds.

    4. It may take 2-3 'scanning' cycles (30 seconds) for your Freedom's to connect to the MySound app.

    5. Once connected the battery icon and headphone name will appear at the bottom of the app.

    6. So we can improve this experience for you, the developers would like to know what OS you are on and if you have any other Jaybird products in the same room as you?

     

    0
    Comment actions Permalink
  • Dave1996
    Hi, ive alteady tried this, and i can connect but i cant stay connected more than a few minutes.. i am on the iOS 10.2.1 and my freedoms are the only pair in the room
    0
    Comment actions Permalink
  • bbrac

    @David Gjerde Maybe try this hard reset and let me know if that helps. 

     

    To reset your Freedom buds to their original factory settings, put your buds in pairing mode by turning the buds off then push and hold the center button for more than 4 seconds until you see alternating red/green LED. 

     

    While the LEDs are flashing red/green double tap the center button. Upon successful party reset, the LED turns orange and your buds turn off. 

     

    NOTE: Once your buds have been reset and you power on they will automatically go into paring mode. Select “Forget” or “Remove”  Jaybird Freedom from your device’s bluetooth menu and pair again.

    0
    Comment actions Permalink
  • Dave1996
    @Beau Brace  tried it three times, but i can still not stay connected if im not inside the app at all times..
    0
    Comment actions Permalink
  • bbrac

    @David Gjerde I am sorry that none of the TR steps have worked so far. I will go ahead and contact our tech team to see what else we can try. I apologize for the inconvinience. 

    0
    Comment actions Permalink
  • Dave1996
    Thank you for that. Will you inform me when you get an answer/solution from them? I know im not alone with this problem though
    0
    Comment actions Permalink
  • bbrac

    @David Gjerde Absolutley, I will update you on here for sure. 

    0
    Comment actions Permalink
  • KaioRiza

    Is there an update to this issue? - Thank you

     

    0
    Comment actions Permalink
  • Madi

    Hi All,

     

    Please be aware that there have been some recent updates to the MySound app which should help with connectivity issues. Please make sure to update your app to the latest version and you should have a better time with getting connected to MySound!

     

    Please let me know if this does not resolve the issue.

     

    -Madison

    Jaybird Customer Experience

     

    0
    Comment actions Permalink
  • KaioRiza
    The App Store says the app was last updated on June 1,2017. I first logged in my issue on June 13. is there an even recent update? At the moment I believe the only solution is to uninstall everything and install it back just to get it working only once again.
    0
    Comment actions Permalink
  • EQ738263

    I have exactly the same issue as the OP.

     

    • Latest version of MySound on an iPhone 6.

    • Latest firmware installed on the Jaybird Freedoms.

    • Latest iOS.

     

    The headphones connect via bluetooth just fine and I have no problem using them.

    It is only the connection to the MySound app that isn't working.

     

    Could you please advice?

    Or at least acknowledge that this is a common issue and try to fix it in the next update.

     

    Thanks,

     

    E

    0
    Comment actions Permalink
  • stevespeirs

    Same issue for me. Headphones connected to iPhone via Bluetooth. Music playing fine via the earbuds. Cannot connect to MySound app to customize the sound output though.

    0
    Comment actions Permalink
  • EQ738263
    Still no solution to this issue? No answer, nothing… This needs to be addressed ASAP!
    0
    Comment actions Permalink
  • EQ738263

    At last…

    Update the MySound app to 1.7.1. released today.

    That fixed the connectivity issue on my headphones.

    0
    Comment actions Permalink

Please sign in to leave a comment.