I cannot get my JayBird X2 to connect to any Bluetooth device.

Comments

10 comments

  • Logi_Bruce

    Hello Leygh,

     

    I am sorry to hear that you can't connect your Jaybird to any Bluetooth device. This is not the quality we're expecting from our product.

     

    Can you confirm the phone is the only enabled and paired BT device in the vicinity?

    We need to do some steps:

    -Move the headphone closer to audio source.

    -Try different Music App

    -Disconnect Audio source other Bluetooth devices and 3rd party apps

    -Try different audio source or Phone

    -Check and clean any debris on your device

    Clear cache on Android phones

    Reset:

     

    1. Turn headphones off

    2. Put headphones in pairing mode (hold middle button for 6-8 seconds until it says, "Searching for your Music Device")

    3. LED will flash red and green

    4. Hold both volume buttons down 6-8 seconds, this will reset the headphones

    5. LED will flash orange 3 times

    6. Delete Bluetooth profile from device

    7. Put headphones back into pairing mode and connect them to your device.

     

    After reset, let's check pairing mode:

    1. Make sure Bluetooth on your device is turned on.

    2. With your buds turned off, press and hold the Power Button until you see the LED flashing red/green. When the LED flashes red/green, the buds are ready to pair.

    3. A voice prompt will say “Searching for your music device”.

    4. Select the Jaybird device in the list of discovered devices to connect. Once connected, you will hear “Headphones connected” from your buds.

    -It will also help to turn your audio device Bluetooth off for at least 10 seconds and then turn it on again. Forgetting the bluetooth device on the list may help so we can also try that.

    -If all else fails, try to connect to different Bluetooth Device for us to isolate the issue.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Leygh

    I have tried all of this several time with no success. Please advise.

    1
    Comment actions Permalink
  • Manoj V

    I have the exact same issue. I tried the steps multiple times and it wont work. Seems the bluetooth of Jaybird X2 is at fault where its unable to pair with any other device. The device is not damaged at all.

    Is there any fix for this ? Or should we think lifetime of Jaybird X2 is short ?

    Can you please suggest. Thank you!

    0
    Comment actions Permalink
  • Someshwar Dutta

    i am having the same issue with my jaybird x2, the device is not appearing in any Bluetooth list. I tried resetting my jaybird and phone however the device is not showing in my laptop also. Please help me to fix the issue. 

    1
    Comment actions Permalink
  • James Robin

    So frustrating looking EVERYWHERE for a solution...the troubleshooting articles ALL suggest the same obvious, things over and over again always with the same results? Confirm bluetooth is on...most current device update installed...restart device...full battery...forget device...pair them again...reset by holding volume controls...ALWAYS with the same results? Can we PLEASE get some help that actually works? I have wasted ALOT of time on this and I’m ready to drop them for another brand?

    0
    Comment actions Permalink
  • Jon Ramirez

    I have tried all the above suggestions, but to no avail. Please advise on more suggestions. 

    Is it possible the Bluetooth software are not up to date? 

    Respectfully,

    Jon Ramirez

    jon127.ramirez@icloud.com

    0
    Comment actions Permalink
  • Lee Faulkner

    Hi,

    I came across this thread because my X2’s are having the same issue. I restarted my device, reset the earbuds, and tried multiple devices but nothing works.

    Was a solution found or shared that I missed? I have liked my X2’s up to this point. Was going to get some Jaybirds for my fiancée for Christmas but not sure about the product anymore.

    Thank you all for any help you can provide.

    0
    Comment actions Permalink
  • Bruce Peterson

    I have the same problem. Just one day it stopped saying “Headphones connected” after power up. I have tried the above suggestions to no avail. Hopefully this isn’t planned obsolescence.

    If there is a solution would appreciate help, thanks.

    0
    Comment actions Permalink
  • Christian Dominguez

    Having the same problem and have raised this to the customer support. 

    Unfortunately it is not under warranty as 1 year have passed. 

    Too bad. I liked it.

    0
    Comment actions Permalink
  • Kristen Gleason

    I had trouble at first. I reset them per the instructions. Turned them back on. Then I held down both volume controls at once, the search voice then sounded and they connected right up! 

    0
    Comment actions Permalink

Please sign in to leave a comment.