My Jaybird X3 headphones won't turn on

Comments

27 comments

  • Bruce B.

    Hi ILoveLamp83,

     

    I am sorry to hear that your Jaybird X3's won't charge or turn on. This is not the quality we're expecting from our product.

     

    I've sent you an email with details on how we will proceed with this one.

     

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

     

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
  • rocky mahidi soliano

    Hello,

    I have the same issue. How do i fix this problem? I purchaed it via Amazon.

    Thanks and best regards,

    Rocky
    Rocksoliano@gmail.com

    1
  • Ashwin Venkatraman

    I have the same problem after having jaybird for under a year. Have charged and they just won’t turn on. Can you please let me know how you can rectify this?

    My email is venkatraman.ashwin@gmail.com

    Thanks

    0
  • 建 安

    I having a same problem on my X3 headphone just after a year(no more than 13 months) cannot turn on. Is any chance can recover this? please share with me.

    My email address is annann6272@gmail.com

    0
  • BikeBradB

    unfortunately,  I have the same problem as everyone else.   i bought and extra charging port thinking that was the problem.   It worked for a while and now I am back to a dead, non-charging X3.     Very sad that the product worked for about a year like most people say, then KAPUT!!!    When they worked, I really like them.  

    0
  • BikeBradB

    unfortunately,  I have the same problem as everyone else.   i bought and extra charging port thinking that was the problem.   It worked for a while and now I am back to a dead, non-charging X3.     Very sad that the product worked for about a year like most people say, then KAPUT!!!    When they worked, I really like them.  

    0
  • Andrew Fairlie

    Same here. Almost Identical. X3s worked great for around 12 months now nothing. Green Charge light but nothing else. Disappointing as I liked them a lot...

    0
  • Feng Lee

    I have the same problem after having jaybird for under a year. It just happened so suddenly. Charged shows green light but they just won’t turn on. Can you please let me know how you can rectify this?

    My email is joshualeefeng@gmail.com

    Thanks

    0
  • Junior Matos

    Eu tenho o mesmo problema depois de ter jaybird 4 por menos de um ano. ele veio a estragar, Carregado mostra luz verde, mas eles simplesmente não acendem depois que voce tira do carregador, Você pode me informar como você pode corrigir isso?

    0
  • Jason0081

    I've got the exactly same problem. It's just happened out of the blue.  Has anyone successfully fixed the problem?

    0
  • Eduardo Ag Rez

    Same with me for the SECOND time, first time was with Jaybird X3, then Jaybird gave me a new X4 model.

    Now, after 5 months, the X4 don't power up anymore. Light still green due charging but don't work. Tried both reset method without success. Very disappointed. I don't recommend this earbuds.

    2
  • Audun Lindhjem

    Unfortunately I have encountered the same issue. The ear buds was fine until yesterday. I turned them off with 50% battery, and when starting them today they are dead. Is there any change to get them fixed? Or should I drop them off in the garbage? I have tried the suggested solutions above with no results.

    0
  • taeyeons wife

    i literally have the same problem. I used them and then I putted them to charge, it was fine, like red to green as normal, when I was going to use them, the wouldn’t turn on. I’m so disappointed, I loved them so much, please tell me it fan be fixed.

    0
  • SB

    Hi
    Sad to say I’m having the same problems. Originally tried the 8 press method when they wouldn’t charge and then they did start to charge but the led never changed to green after 5 hours. I now can’t turn them on, pair or charge.
    Please help.
    I love these earphones. Nothing comes close, but to say I’m disappointed they haven’t even lasted 6 months is an understatement.
    I bought them from Currys in the UK.

    Please advise next steps.

    Many thanks

    0
  • Robert Grainge

    A man named Molerk proposed this solution so I'm crediting him. This worked for him and now its worked for me.

    If your Jaybrd X3s aren't charging found it's because the contacts become corroded or oxidized, likely due to sweat from resting against the back of a head. Either way an insulating layer forms on the charging contacts, preventing charge.

    Do the below and it will work.

    1. Use a dry scothbrite pad on the headphones charging contacts as well as the charger's contacts to brush away the corroded/oxidised layer.
    2. Spray a cotton bud with isopropyl alcohol and then wipe both.
    3. I then used a dry cotton bud to clean it all up and charged them overnight.

    I hope this helps you all as much as me.

    Cheers.

    Molerk, you're a legend, thank you!

    0
  • SB

    Thanks Rob, appreciate the comments.
    I can confirm that i saw this advice in another feed and as a result tried it..... and it worked.
    My x3’s now charge and did work fir about 30 minutes.
    Unfortunately my problems have evolved and I have a new problem. They now keep turning off after 30 minutes or so for no reason. Sometimes I can just turn them back on but also have to re-pair and sometimes i have to do the 8 press reset.
    Jaybird is in contact but no solution yet.
    Appreciate any additional comments.
    Thanks again Rob

    0
  • Pablo Ar

    I have the same issue.
    While I connect the headphones to the power outlet the Led light goes green. I unplugged them and they don't turn on. As the battery doesn't work or something like that.

    My email is arizpepablo@hotmail.com
    Hope someone can help me please.

    0
  • Sebastian Bankston

    This have been my is after 3 weeks of use. I just gave up.
    While I connect the headphones to the power outlet the Led light goes green. I unplugged them and they don't turn on. Does anyone have a solution after many years?

    sebastian.bankston@gmail.com

    Would love to be able to use these X3s again!

    Victory...once more

     

    0
  • Ale Salazar

    Same problem here, was using them yesterday, turn them off with 60% battery, and today they just stopped working, any chance or idea on how to fix them

    0
  • Alexis Gillain

    Exact same problem here.

    The earplug can charge, even if I have to play with the cable on the charger dock to make it work, but they won't turn on.

    It seems there is clearly a design defect on this product, I think the remote doesn't handle the sweat.

    I tried the firmware update as well, it doesn't work.

    0
  • Becky Smith

    Following as I am having the same problem.  I was relying on my jaybirds for remote work as well as my runs.  They are not that old and I expected more life out of them for the money.

    0
  • BikeBradB

    I have given up on the X3s.   I am now using the Tarah Pro and Vistas now and haven't had any problems.  (yet - lol) 

     

     

    0
  • David Osvaldo5291

    Hi, I have the same problem, my X3 don't have response in any way. is death. Please help

    0
  • BikeBradB

    your out of luck. I never got mine working again. on a good, I purchased the Tara pro and Vistas and so far they have been rock solid.

    0
  • Katherine 3608

    Same issue. Seems to be quite common. Is there a resolution? They stopped mid use today. When plugged in I get a green LED light but they won’t turn on.

    0
  • Mimi Dao

    Same issue as Katherine. Mine also stopped working today and I'm posting only 6 hours after Katherine. When plugged in I get a green LED light but they won’t turn on.

    0
  • BikeBradB

    gave up on the X3s and moved on to the Vista and Tara Pros.   So far, I have no problem with those models.   

    0

Please sign in to leave a comment.