MySound app does'nt pair with Jaybird X3 .

Comments

4 comments

  • Madi

    Hi there!

     

    Please try the following to connect your Freedom's/X3s to the MySound app:

    1. Make sure your Freedom's/X3s have been paired to your listening device. This needs to be done through your devices Bluetooth Settings.

    2. Make sure your Freedom's/X3s are turned on.

    3. Open the MySound app and 'scanning' will appear at the bottom of the screen. If 'No headphones connected' is displayed, please wait and MySound will search again after about 10 seconds.

    4. It may take 2-3 'scanning' cycles (30 seconds) for your Freedom's/X3s to connect to the MySound app.

    5. Once connected the battery icon and headphone name will appear at the bottom of the app.

    6. So we can improve this experience for you, the developers would like to know what OS you are on and if you have any other Jaybird products in the same room as you?

    Let us know how it goes.

    0
    Comment actions Permalink
  • Vemuri

    No Luck, even after 10 Scanning cycles . pls fix this , i'm using android 6.0.1 on galaxy S6.

    0
    Comment actions Permalink
  • fooly

    Pair it via the phone like for any BT device, ignore the app wanting to do it.  What works for me when this happens after being paired, Galaxy S7, is to jump out of MySound and go to the phone's Bluetooth Settings of course the X3 shows as paired and connected.  Returning to MySound, the X3's are now detected.

    0
    Comment actions Permalink
  • Vemuri

    @Sal Olivares : thx this works !

    0
    Comment actions Permalink

Please sign in to leave a comment.