My Jaybird X4's are fully charged but won't turn on...

Comments

32 comments

  • Official comment
    Bruce B.

    Hi Robert,

    Thank you for reaching out. I am sorry to hear that your X4 stopped working.

    - Try a different power source/charger
    - Computers are the best and safest method, as is anything 1 AMP or less.
    - Car chargers produce a much greater power supply and should be avoided.
    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2.5 hours,
    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.
    - Avoid charging your headphones after exposure to sweat.
    - Make sure charging port/cradle is clear of any debris.

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

    Warm Regards,
    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

  • Bruce B.

    Hello magman1621,

     

    I am sorry to hear that your Jaybird X4 won't turn on.

     

    I've sent you an email with details on how we will proceed with this one.

     

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

     

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    -1
  • Robert Castillo

    I am having the exact same issue and I just bought these X4 headphones from Best buy about 2 weeks ago.
    They stopped working today and the battery was at 80%. When I plug them in to charge the solid green light turns on. They are now completely unresponsive. In addition I charge them on a 0.7 Amp output charger.
    Please advise.

    Thank you,
    Robert

    0
  • Robert Castillo

    Hello, I received your reply with charging instructions. Please forgive me if I failed to mention that when charging the indicator light is solid green, therefore indicating that the device is fully charged. Therefore charging instructions do not help in this case. They are y
    completely unresponsive and fully charged.

    Purchase date 7/10/2019 serial#1839SDC032E8

    Please advise.

    0
  • Bruce B.

    Hello Robert,

    Thank you for getting back to me and for providing the necessary information.

    I also sent you an email so we can get more information as well as to process your request.

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

    Jaybird_Bruce
    Jaybird Customer Experience
    #PowerYourPassion

    0
  • Ashley

    I’ve been using jay bird for 3 years now and this past year has Been the worst!!!!! I had to replace my x3 because only one earbud would work! Then using X4 for 6 months same issue so they replaced them it’s been one month and my x4 will not hold a charge i’ve tried everything that they have said on these forums!!!!! It’s really upsetting because I count on my headphones every morning

    0
  • Lynn Chotowetz

    Hi,
    I’m having the same issue as Robert above. When connected to the charger the earphones display a solid green light. When I try to turn them on with the power button they are totally unresponsive. What do I do??

    0
  • Erwin Dejucos

    Im having the same issue as well. It just died on me and wont turn on. 

    Charging the unit on my laptop also indicates that it is fully charged,

    Any idea how to proceed about getting it fixed?

     

    0
  • Wesley Santos

    Im having the same issue as well. It just died on me and wont turn on.  Charging the unit on my laptop also indicates that it is fully charged. WHat do I do?

    0
  • Jenene

    I am having the same issue. They show green light and fully charged but just won’t turn on. I found my receipt and I have had these for 13 months so just over the manufacturer’s warranty. Is there any way Jaybird can fix or replace? 1 year is just not long enough for this price.

    0
  • Luke McKenzie

    I hate to repeat the bad news... but I am having the same issue as the multiple people above have as well. Also, the exact same issue occurred with my previous pair of X3 headphones. Very frustrating to have this happen two purchases in a row, but please let me know if there is any solution that has worked for others or if Jaybird is willing to do anything to resolve. Thanks very much. 

    0
  • Daniel Hanley

    Mine just started doing this as well.  I just received these X4's 4 days ago and only went on 2 runs with them.  

     

     

    0
  • MW

    Don't know if this helps anyone but I had the exact same issue.

     

    Fully charged, went for a run then tried to turn them on the next day and no response. I charged them up again just in case, green light was on but they still wouldn't turn on.

    I managed to get them to work by plugging them into my PC USB port and then turning them on whilst they were still attached to the charger. They appear to be fine now.

    For how long, who knows?

    2
  • MW

    Well, they turned on, but then turned off about 5 seconds later.

    The first time I tried this it said the battery was 80%.

    I then tried again the following morning and the battery lost 40% overnight.

    Again at lunch and it said battery was low.

    There's obviously a fundamental issue with these.

    0
  • MW

    I have contacted support to ask for the procedure for returning my X4s. It's been 4 days and I've not had a response.

    0
  • MW

    Just to conclude this for me. Support did finally get back to me here, but I already had a replacement on the way thanks to Twitter.

    If you DM Jaybird on Twitter you will get a really fast response.

    0
  • Kean Yoong

    This same problem goes to my X4 as well. It was actually a replacement set for my X3, and this X4 just lasted not longer than 6 months. :/ 

    0
  • MW

    Well my replacement pair have just failed. Had them less than a month and I've probably only used them for 3 hours and one of the buds has suffered a volume drop.

    0
  • dcoyle

    I am having the exact same issue with my X4. The green light is on that they are fully charged but they wont turn on.

    This is a recurring problem for me. It happened with my X3s and now it has just happened with my replacement X4. I have read trough all of these comments and tried all of the troubleshooting suggestions but none have worked.

    0
  • edgar moreno

    I hate to be the bearer of bad news, but it can't be that I am too having the same issue. There is truly some type of issue with these headphones.  I have tried everything, and nothing works. 

    0
  • Jonathan Holt

    I am having the same issue that everyone has expressed above. Plug into the computer it shows the green light but once you unplug and try to turn on nothing happens.

    0
  • Andrew9688

    In having the same problem.
    X4 completely unresponsive now.
    Gutted.

    Green Light shows on responsive. $229NZ for this. Looks to be a common issue. What a crap product.

    0
  • MW

    So, unfortunately another update.

    My third set have now started crackling and popping in one ear as soon as I turn them on.

    These things are absolute junk.

    1
  • Andrew9688

    It's a shame really reading through these comments. 

    Jaybird doesn't seem to want to take responsibility, I've seen the usual cut and paste reply from a guy called "Bruce", probably an intern on a low salary in India. 

    The bigger concern is that they don't read what the problem is, they don't understand it before they reply. 
    Good luck on here customer with the "Unresponsive" main button issue. I don't think you'll get an honest straight answer. 

    0
  • Lee Dobrec

    6 Months seems to be the theme. Please advise, is this a replacement situation or is there a reset potential here? Paying this kind of $ for sports earbuds, and not having them last or have chronic quality issues is going to drive me to another brand.

    0
  • Daniel Cabral

    It looks like I am having the same issue, and I am disappointed to hear so many people have the same problem without a solution. What can be done? 

    0
  • Mark Mullington

    I also have the same issue. Very concerned that so many people are have this specific issue, but Jaybird have not provided any guidance for how to resolve. If in fact it is a fault with the product, Jaybird should be offering to replace for anyone suffering this fault.
    Jaybird, where are you???

    0
  • MW

    I am now on my fourth set. I feel like I keep getting fobbed off with b-grade stock until my warranty runs out.

    These are obviously not fit for purpose.

    Never again Jaybird!

    0
  • Andrew9688

    I was on by 2nd set. when this happened again. Not happy... 

    I have now changed to "Beats PowerBeats Pro True Wireless Sports Earphones" -
    They're more expensive but I'm happy that I've made the change. Better quality audio, they fit perfect, plus they are native to iPhones like the Airpods Pro. 

    Goodbye Jaybird and never again!!!!!! 

    0
  • Neil Mercer

    Replaced my X4s a few weeks ago due to a failure with the red light stuck on. Used my new pair for 2-3 hours, exactly the same issue as everyone else above. Clearly a massive design fault. 

    0

Please sign in to leave a comment.