My Jaybird X4 headphones will not turn on, even when placed in to charging dock the light stays a solid green take them out and will not charge. I have tried all of the troubleshooting problems I have found still nothing happening.

Comments

18 comments

  • Bruce

    Hi Cedrinathan,

     

    I am sorry to hear that your Jaybird X4 won't turn on. This is not the quality we're expecting from our product.

     

    I've sent you an email with details on how we will proceed with this one.

     

    The easiest way to contact us from here on will be via the email I sent, if you do not get the email, please give us a call on 866.244.3399.

     

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Kellyelizabeth

    Hi I am also having the same exact issue. Can you please email me as well? Kellyelizabethb@icloud.com. I was planning to use this next weekend for my half marathon.

    0
    Comment actions Permalink
  • Nicolas NESME

    Hi

    Same here! Sent an email already.

    thank you

    0
    Comment actions Permalink
  • Sebisob

    Hello I'm a French user of Jaybird x4 and I've the same problem since 3 days. I can't turn on my headphones except when they are plugged on the charging dock. A solution for this problem?????

    0
    Comment actions Permalink
  • joe99093

    Hi I have exactly the same problem. Please can you send me the fix as well?

    0
    Comment actions Permalink
  • cprocha

    Hi, same problem solid green, and wont turn on. Tried all trouble shooting recommendations. Only 5 months old.

    0
    Comment actions Permalink
  • Nandu123

    Same problem here, this is the second device that it's happening on. First the X3's and now the X4's

    0
    Comment actions Permalink
  • joe99093

    Obviously leaving comments in this community is useless as no one from Jaybird listening to end users, also no response from support team after creating ticket for 2 days. I’m so disappointed to Jaybird’s product and swear do not buy any of this brand.

    1
    Comment actions Permalink
  • baddong

    I'm facing same issue with my X4!

     

    Initially I tried charging and ensuring that I disconnected them from the power after about 2 hours. The light was green and when I went to use them they stated 80% only.The next day I tried to charge them and the green light came on immediately.

     

    Now, they no longer turn on and I have tried to reset them but not able to. Now totally not working. Plug them in again, immediately the light is solid green.

     

    I've been charging them using laptop since it was suggested that computer has lower AMP than normal power socket chargers.

     

    On top of that, no response from Jaybird! Really disappointed.

     

    1
    Comment actions Permalink
  • Andreas Ekblad

    I have exakt the same problem! Need help to start my Jaybird X4.

    0
    Comment actions Permalink
  • Garrett Skovira

    Hello my Jaybird X4’s will not stay on. They will turn on and say battery fully charged and then promptly turn off and will not come back on. I know they are fully charged but refuse to stay on, very frustrating as they are not even a couple months old.

    0
    Comment actions Permalink
  • Danny KONE

    Hello, I have exactly the same issue. I have contacted the support that promise a response within 48h but I have no hope as it seems a commun issue and obvisously jaybird has no solution. disappointed !

    0
    Comment actions Permalink
  • André Leite

    I have the exact same problem here. I've been using my X4's for the past 6 months with no problem. Last week it started not to turn on, even if i put it into the charging dock (and it turns solid green). Any answer from Jaybird? I'm placed in Brazil, by the way

    0
    Comment actions Permalink
  • Leonel Espinoza

    I have the same problem, jaybird working for 6 months and then the same problesm, it shows full battery and it is not possible to turn it on. Please advise.

    0
    Comment actions Permalink
  • Greg Pohoski

    Same issue, anyone find a resolution?

    0
    Comment actions Permalink
  • Kenny Tan

    Have exactly the same issue here.. sometimes it works after 1-2 weeks and I believe it has fully discharged and it did some kind of reset. Please give us a solution.. kinda sad and didnt expect a sub-standard product from Jaybird

    0
    Comment actions Permalink
  • Aditya Putra

    Have the same issue with my X4. Cannot be turned on and the light is solid green when attached to charger dock.
    My earphone is not even 2 months old. Solution is really appreciated, Jaybird. Thanks!

    0
    Comment actions Permalink
  • Min Pyi

    Have the same issue with my X4. Been using them for a while and worked well but one day can't turn on anymore. Tried charging at computer but shows the solid red light only and never shows green light for fully charge anymore no matter how long I charge it. And can't turn on anymore.

    I accidentally found out that the earbuds works while charging only. Can use them only while charging and once disconnected from the charging dock, they don't response anymore.

    0
    Comment actions Permalink

Please sign in to leave a comment.