My jaybirds won't charge. I don't think it's the USB cable. The light won't even turn red when it's plugged in.

Comments

14 comments

  • Engelbert

    Hi Brianc60,

     

    It's sad to hear that your Jaybird X3 will not charge. Please try an 8-button process that can help resolve the issue with the headset.

     

    1. Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    2. When finished, plug the headset into the charger for 2.5 hours and check the color of the LED status lights.

    3. Power ON the device by holding the power button for 10 seconds or more.

     

    NOTE: Most of the time if the headset turns RED, it will charge and function normally again. Make sure to fully charge the headset when the light is red.

     

    Also, try a different USB cable and power source then check if the issue persists.

     

    Feel free to post back for the results or additional information.

     

    Warm regards,

    Egie

    0
  • Brianc60

    I don't think it worked. Does the fact that the earbuds still turn on help with deciding whether its the jaybirds or the charger that's broken? Also It didn't work.

    0
  • Nirvana15

    I am having the exact same problem.  Got X3s for Christmas and worked great for 3 months.  Suddenly 2 weeks ago, they will no longer charge.  Red light does not come on when plugged into cable.  I tried the 8-step procedure above with no luck.  Please help!

    0
  • Brianc60

    you can return them and get a refund even if you didn't buy a warranty. I called them. Also you can get a refund if you bought them from different places.

    0
  • VMoney

    I had the same problem and it took me a couple of tries for the "8 button process" but my earphones started charging again. Thank you! It makes a difference that you press the power button 8x then hold for 5 seconds on the 9th press (my mistake was holding on the 8th press for 5 seconds). Also, you must repeat the process twice after the 1st sequence - So 3x times total.

    0
  • Mary2Sy
    Same thing as mine...I bought my Jaybird on April 2, 2018 from best buy. The charger was working fine the first 2 weeks and now it's not working anymore. I tried to do the 8 button process but still no light coming out to indicate that it is charging. My earphone is working fine and still has 2%. I tried to change the cable too but it's still not working. Maybe the charging dock has a problem? It is fully seated though.. I can't even return the product anymore because I threw the box and receipt away....
    0
  • yclian

    I am having the same problem, after 2.5 months. I bought mine at Target SF Central, and the battery started to deteriorate (leak overnight) within a month time.

     

    The battery no longer charges (it always says "Charge Me" as soon as I detach it from the secondary battery) since yesterday and I am no longer in US right now to return this.

     

    What can I do?

    0
  • Frankboltcft
    After a month of not having headphones, going through the process of getting a new charger, endless 8 button reset tries, and realizing it still didn’t work.. right as I was about to lay them down to rest, I decided to replace the usb cube connected to the wall outlet... Back to life. There was nothing wrong with the headphones or the charger at all. Hope this helps.
    0
  • Tabs6325

    Im also having this issue -

    I can not turn on the earbuds

    I put the earbuds on charge and it goes amber then red

    now going green however still can't turn on

    tried reset routine several times however to no avail

    I just recommended these earphones to two friends and now questioning decision

    0
  • rh_baldwin

    I have the same problem but with a variant. After pressing 8 times and then holding for five seconds, the LED flashes quickly between red and green. I have tried doing that process two times, three times, four times....doesn't work.

    0
  • molerk

    I've experienced this issue and i've seen similar discussion on many jaybird support forums; the reset likely will not solve your issue. Neither will a new USB cable. I've owned these headphones for 2+ years and i've fixed this issue several times. I've found that the contacts become corroded or oxidized, either way an insulating layer forms on the charging contacts, preventing charge. When experiencing this issue you'll likely find that the charging piece light is on, and it is the headphones which have no light. This indicates that the charge is not reaching the headphones. To fix; I use an abrasive (scotchbrite pads or a wire brush) to clean both the charger pins and the headphone contacts. I then clean the surfaces with isopropyl alcohol. I use q-tips and isopropyl alcohol to clean the recessed headphone contacts. This has worked for me on three occasions, and my X3's are still going strong. I nearly pulled the trigger on the new UA Rock wireless earbuds... but as long as these X3's keep rolling i'll stay with jaybird. I hope this fix helps everyone experiencing this issue!

    0
  • w rod

    I didn't bother with the reset. I cleaned the charging contacts on the earbuds with rubbing alcohol and a toothpick and it worked.

    0
  • Robert Grainge

    Hey Molerk,

    I just want to say thank you for your advice above. I did exactly what you said and my headphones are working again! I'm actually so happy!

    Guys, if your headphones aren't working do what the man above says.Molerk, you're a legend, thank you!

    0
  • Juvenal Gonzalez

    Wow! it was the cable...

    0

Please sign in to leave a comment.