MY JAYBIRD X3 WILL NOT TURN ON

Comments

20 comments

  • Engelbert

    Hi Sexyalpha,

     

    I am sad to hear that your Jaybird X3 has stopped powering ON. I'll be glad to help you with the concern.

     

    Please try an 8-button process that can help resolve the issue with the headset.

     

    1. Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    2. When finished, plug the headset into the charger for 2.5 hours and check the color of the LED status lights.

    3. Power ON the device by holding the power button for 10 seconds or more.

     

    NOTE: Most of the time if the headset turns RED, it will charge and function normally again. Make sure to fully charge the headset when the light is red.

     

    Hope this helps.

     

    Warm regards,

    Egie

     

    0
    Comment actions Permalink
  • WaldmanG

    Any luck? i have the same problem with my X3. 

    Bought them couple of months ago and took great care of them. two days ago they suddenly stopped working(?!?!)

    0
    Comment actions Permalink
  • maxpower82

    I am having the same problem I charged them used them the other day charged the battery and now they don'r run on tried this process and no luck tried charging again no luck

    0
    Comment actions Permalink
  • FinnBell

    I'm having the same problem. I have tried the above advice. When I charge the headphones the green light appears on the control. Any advice would be much appreciated.

     

    Thanks,

     

    Finn

    0
    Comment actions Permalink
  • Laurya

    I have the same problem. But I bought my jaybirds X3 less than 3 weeks in US and I live in Brazil. What should I do ?

    0
    Comment actions Permalink
  • WaldmanG
    On my case i simply called them and asked the earbuds to be replaced. As I live outside of the US it took them some time but eventually I got the earbuds. I want to believe they made a change in the electronic inside as I notice lots of people with the same issue..
    0
    Comment actions Permalink
  • DHagner57

    Same issue here.  Purchased less than a month ago.  No Power On, just a green LED when I connect the charger.  No improvement after the 8 button procedure.?

    0
    Comment actions Permalink
  • bshodokai

    i have the exact same problem, and i cant submit a support email because of a bug on your website form.

    0
    Comment actions Permalink
  • Crlsrm
    I'm having the exact same problem and pressing buttons won't help at all. I don't know what to expect.
    0
    Comment actions Permalink
  • d65535

    Same problem here

    0
    Comment actions Permalink
  • rib1

    Having the same problem.

    0
    Comment actions Permalink
  • rszmulew

    me too. these are my third pair. they are great when they work, but they simply break and need to be replaced

     

    0
    Comment actions Permalink
  • LaTanka

    I'm having the same issue to. It is ridiculous that no one from their support team has answered anyones questions in all of these months.

    0
    Comment actions Permalink
  • Chenss

    I'm having the exact same problem charging is always green light can't power on. Email them no reply.

    0
    Comment actions Permalink
  • Huggie

    I am now having the same problem! I've had the X3 headphones for about 5 months. Recharged about 8 times during that time using 5 v charger per instructions, and now they won't turn on. Solid green LED when plugged into the charger, but then won't turn on. Tried both resets (normal and 8 button). Nothing working. Want a new pair because I like them when they work, but am leery bout having the same problem occur again with a new pair.

    0
    Comment actions Permalink
  • LaTanka

    Update: if you call their office and explain what's happening with your headphones they will have you return the defective pair for a new one. Problem has been how long it's taken them to deal with this. My shipping label took three business days (TR,F&M) to get to me and the shipping of the headphones alone has taken a week to this point and the headphones aren't there yet. Was told I'd get word on when they were mailing me my replacement but this experience has been awful. I suggest all try to get a replacement but just know it is by no means a quick process. Not happy with this at all but it's better than nothing.

    0
    Comment actions Permalink
  • Chenss

    Hi, did anyone here connect with iWatch ? I had 3 Jaybird and 2 other brand of earphones after connect to iWatch all can't charge anymore. Don't know which is the iWatch or earphone problem.......

    0
    Comment actions Permalink
  • pete9781

    Sae problem with me. I think their batteries only have 120 cycles in them so people that use them every day and charge them every day they only last 120 days or three months. They will replace one pair but they wont replace another. They should tell you this before you buy them

    0
    Comment actions Permalink
  • 建 安

    same here, after a year my X3 cannot turn on. feel dissapointed of this.

    0
    Comment actions Permalink
  • Eduardo Ag Rez

    Same with me for the SECOND time, first time was with Jaybird X3, then Jaybird gave me a new X4 model.

    Now, after 5 months, the X4 don't power up anymore. Light still green due charging but don't work. Tried both reset method without success. Very disappointed. I don't recommend this earbuds.

    0
    Comment actions Permalink

Please sign in to leave a comment.