My Jaybirds X3 are not charging,

Comments

43 comments

  • Madelamaza

    hmmmm hello

     

    0
    Comment actions Permalink
  • Madelamaza

    the headphones do work for some reason but they cannot charge btw

     

    0
    Comment actions Permalink
  • dehayst

    SAME ISSUE. Support didn't seem to know what was up and said they'd never heard that before. So they sent me a new wire and charger, but still not taking a charge. Must be in the headset. Earbuds are stuck at 20% charge. LED light on buds work when I turn it on/off etc. However, never lights up once I connect to the charger and never takes a charge. I'm afraid to use them and run it down to zero because they'll never charge again. I just got them for xMas.

    0
    Comment actions Permalink
  • daniel___89

    the tame things have been happening to me!!!

    0
    Comment actions Permalink
  • QWRTY

    I have the exact same issue. The only difference is that mine quickly flash the red LED light (about 1-2 seconds) to indicate that they are charging and then it turns off, and then no charge is received at all. I tried using a different micro USB cable as well and it did not work. Support tells me to try doing that 8 second reset with all the buttons, but that absolutely has not and does not work. Definitely very frustrating!

    0
    Comment actions Permalink
  • Mannu

    I have the same issue, my headphones turn on and play but they are not charging.

    and since i bought my brother a pair as well I tested my charger with his head phone and vise versa and mine still doesn't charge but my brothers charges on either one.

    It all happen couple days back when I went to work with something around 78% charge, I used them during my break and then they were in my pocket for about 6-7 hours before i got home and tried to charge them and they weren't charging anymore.

    I received this response from support but it haven't worked for me. Let me know if you guys try this and it worked.

    Screen Shot 2017-02-08 at 3.54.00 PM

     

    P.S. I have only bought both headphones 2 1/2 month ago

    0
    Comment actions Permalink
  • QWRTY

    Your story sounds just about identical to mine. Got mine for Christmas and now they do not charge. I was told to do the same thing, but that absolutely does not solve the charging issue haha

    0
    Comment actions Permalink
  • CA714

    Same issue here. Seems like a manufacture defect if you ask me. I bought 4 for xmas. So far I've had to exchange one pair and now my daughter's pair is not charging exactly the same as all others on this thread. 

     

    I know the original cable and charger is working fine because my pair charge perfectly on a MacBook Pro and via a 1amp wall outlet charger. 

     

    IMG_1848

     

    HELP!

    0
    Comment actions Permalink
  • teachthom

    Same same.  Just bought a pair today, and wanted to top them up before using them...not taking a charge, the 8 sec reset doesn't do a damn thing either.  Boo :(

    0
    Comment actions Permalink
  • lmendes_rio

    Exactly same thing here . Did a reset and now instead of a red light when I plug the earbud, I get a green light as it is fully charged. It does not turns on outside the charger. I bought it on December. I have a race this weekend and that was the reason why I had bought them in the first place. Very frustraded.....

    0
    Comment actions Permalink
  • teachthom

    I ended up taking them back to where I bought them.  The people at the store tested them, and figured the charger wasn't working, so I got a new set and everything seems fine now.  Guess maybe the charger (the tiny little itty bitty dock thing) is faulty?  

    0
    Comment actions Permalink
  • Mannu

    I just had a chart with an agent and he asked me to do these steps. Right now my X3 are still not indicating that they are charging but he have asked me to leave them charging for 2.5 hours

    You guys try and let me know if that works for you

    Screen Shot 2017-02-10 at 11.09.46 AMScreen Shot 2017-02-10 at 11.10.09 AMScreen Shot 2017-02-10 at 11.10.47 AM 

    0
    Comment actions Permalink
  • CA714

    @Mannu - Let us know if this works. I did the exact same thing and nothing for me.

     

    Thanks. 

    0
    Comment actions Permalink
  • Mannu

    @Jaime Cortez  did they gave you a new pair then

     

    0
    Comment actions Permalink
  • CA714

    @Meeran Mamoon I'm in the process of getting mine replaced. Just waiting for their reply to provide shipping instructions. 

    0
    Comment actions Permalink
  • lmendes_rio

    Mine will be replaced as well. BestBuy don't accept returns on earbuds so I will need to send my unit to Jaybird to only after get a new one shipped back to me. I will have to race tomorrow with my old and reliable Bose. Very frustrated.

    0
    Comment actions Permalink
  • QWRTY
    Yeah well there is obviously a pretty major defect in some capacity if a significant amount of people are having to send their headphones back. It would be nice if they just acknowledged this and did not try to fabricate some nonsensical reset that absolutely does NOT work.
    0
    Comment actions Permalink
  • CA714
    @Keith Lehmann exactly
    0
    Comment actions Permalink
  • sujsar99
    I got this one yesterday n it would not charge no matter what !!! Did any of u guys got a replacement or was able to resolve the issue ??? Kindly reply
    0
    Comment actions Permalink
  • Scott1432

    I too contacted customer service about reliability and "soon to be" the other color options, as in the green. pretty generic answer, "we are not aware of the charging issues and keep checking back on the available colors. I started with the first jaybirds (before Logitec took them over) and absolutely loved them. Recommended them to all my fellow runners! Could not wait for the X3's to come out! showed all the new colors. Still waiting on the green to order. About to give up, sad. Also it is not looking very promising by reading the reviews and problems coupled with uninformative customer service and availability. To give some thought on an answer for you, could it be the new owners? Logitec. Or simple an engineering problem? 

    0
    Comment actions Permalink
  • zoltak

    I am on my second pair for the same reason. I had to pay 1/2 price for the second pair because it was just out of warranty. My second pair just started having the same problem today.

    0
    Comment actions Permalink
  • BRM

    Same problem. I've posted a new thread...

    https://support.jaybirdsport.com/s/question/0D53100006kIHRYCA4/my-4-month-old-pair-of-x3s-will-not-power-on?t=1491533299868

    X3's are only 4 months old. Lightly used. Will not power on. Haven't heard anything. Looks like quite a few people are having the same problem.

    0
    Comment actions Permalink
  • DILLIGAFUK

    I have reported this problem 3 separate times, but still no contact from customer services. Very unhappy - Jaybird customer services are total crap.

    0
    Comment actions Permalink
  • BRM

    Customer service got back to me yesterday. They customer service rep has submitted a replacement request. Fingers crossed...

    0
    Comment actions Permalink
  • fhu7

    same problem here. my X3's were several months old... this sounds like it might be a widespread design flaw. i love the X3 but the charger (even when it works) is horrendous.

    0
    Comment actions Permalink
  • Scott1432

    May I give some advice, As earlier posted, before I purchased I read all the reviews and it was not looking bright for the X3's. I went ahead and purchased a pair. Only because I loved my originals ones before the X2's. Sound (and new sound app) I love, they stay in your ear very very well when fitted correctly... Awesome on runs. (marathons) Battery is great. Luckily I have not had charging problems But: the only problem I have is connectivity. I know they changed the antenna placement, which should be even better. But on my X3's they don't have as good of range and often glitch even when the phone is on me. I know it is the new X3's because the old ones work fine. In conclusion I would recommend utilizing Jaybird's chat service on their web site. They were very courteous and helpful to resolve my issues. Thank You, hope this helps. And hang in their with the Jaybirds, still a awesome athletic bud:)   Scott  

    0
    Comment actions Permalink
  • Cohny
    Hi All I seemed to have joined the long queue of people with x3 charging problems. My ear buds arrived with 40% charge and despite all my attempts to charge them, resets, lead changes etc they soon ran down to zero and that was that. I raised the issue with Jaybird, all I got was a ticket number, despite several requests for help I didn't get a response. In summary: a crap product only matched by equally crap support. I've now sent them back for a refund. Anyone recommend outdoor bluetooth earphones that work? Mark
    0
    Comment actions Permalink
  • Kiwi79

    My X3s won't charge either.  I've tried 2 outlets and 2 USB leads.  They're only 8 weeks old.  :(

    0
    Comment actions Permalink
  • JonnieP560

    I have same issue. Fairly new headset from my Jan 2017. Headphones just stopped working and I tried charging. It will not power on unless it is actually connected to the charger and plugged in to computer or outlet. Then it will show that it has a charge (varies from 100% then drops to 18%). I don't think the battery is basically holding a charge anymore. I will give Jaybird support a try.

    0
    Comment actions Permalink
  • PCW

    I too am having an issue with my X3s charging. Purchased them in late January 2017 and they worked fine until about a week ago. Since then they do not hold any charge at all. I submitted an email to Jaybird support and hope to get this resolved soon. Interested to learn, if possible, how some of the above issues were resolved.

    0
    Comment actions Permalink

Please sign in to leave a comment.