Red Light Stuck On - Dead?

Comments

14 comments

  • bbrac

    @Jon Rauschenberger 

     

    Try this,

    Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

     

    When finished, plug the headset into the charger.

    Most of the time if the headset turns RED it will charge and function normally again,

     

    Make sure that if the light is red to fully charge the unit again.

    Try holding the power button down for 10 seconds also some times it takes longer to turn them on.

    0
    Comment actions Permalink
  • jrausch

    @Beau Brace 

    Thanks, I did try these steps but unless I did it wrong it had no effect. See the video linked below - the red light never goes off. I have plugged it into a charger since doing these steps, but it seems to be in the same state. Red light is on and it's not connecting to my phone.

     

    https://1drv.ms/v/s!Am55hmlYcF_bj68e8OJTaru_AHSERg

    0
    Comment actions Permalink
  • jrausch

    After letting the headphones charge for a few hours...they appear to be working again. The red light is no longer stuck on, they powered right up, and connected to my phone.

     

    Not sure what the button press sequence you suggested I try does, but it seems to have worked for me.

     

    Thanks!

    0
    Comment actions Permalink
  • bbrac

    @Jon Rauschenberger Awesome, I am glad to see that the headset is working again. Please let us know if you ever have any other questions or concerns. 

    0
    Comment actions Permalink
  • varu76

    @beau hi, about the sequence... did you hold for 5 seconds at the 8 time? or press for the 9 time and hold for 5 seconds?

    0
    Comment actions Permalink
  • bbrac

    @sharif hage Yes on the 8th hold for 5 seconds. 

    0
    Comment actions Permalink
  • Noobiswayofthinking
    Do I have to press 8 times, then 5 seconds and then immediately press 8times again or do I have to wait for like 5 seconds
    0
    Comment actions Permalink
  • Adhe
    Hi.. Had the same issue, tried 8x 5 seconds but the issue is still there
    0
    Comment actions Permalink
  • lucaev

    Same issue also for me, tried sequence but doesn't work.

    0
    Comment actions Permalink
  • mhilden

    I'm having the same issue and I followed the steps to no avail. I'll try charging overnight and see if it changes anything.

    0
    Comment actions Permalink
  • CraigBird

    Been having the same issue for a few days now, tried the steps above without luck, stuck in red light district.

    0
    Comment actions Permalink
  • yclian

    Same issue here. My Jaybird is always at 0% and it never charges.

    0
    Comment actions Permalink
  • haber
    What worked for me was letting the battery go dead, then when I got home I plugged the cord into the headphones, let them charge a minute and I was able to turn them on and they now work.
    0
    Comment actions Permalink
  • yclian

    You are right @Phyllis Haberkamp?, I had the external battery attached yesterday and it went flat as I forgot to switch off the earphone during dinner. It's back working again.

    0
    Comment actions Permalink

Please sign in to leave a comment.