Is there something wrong with the bluetooth on my X3?

Comments

14 comments

  • bbrac

    @Eric Vierra Try this hard reset and let me know if that helps the connection. 

     

    To reset your X3 buds to their original factory settings, put your buds in pairing mode by turning the buds off then push and hold the center button for more than 4 seconds until you see alternating red/green LED. 

     

    While the LEDs are flashing red/green double tap the center button. Upon successful party reset, the LED turns orange and your buds turn off. 

     

    NOTE: Once your buds have been reset and you power on they will automatically go into paring mode. Select “Forget” or “Remove”  X3 from your device’s bluetooth menu and pair again.

    0
    Comment actions Permalink
  • Elikenui

    Nope.  Doesn't help.  I am going to return them and get something else.

    0
    Comment actions Permalink
  • Elikenui

    The connectivity on the X3 just isn't as good as some other headsets it seems.  I tried experimenting a little more with them because other than the connection issues, I really like the X3's.  I was using the cable clips to make the cable snug against my head for a more secure fit but I found that I went without the cable clips, the connection was a lot better.  I was able to walk with my arms at my side with my phone in my hand and not have the signal cut in and out.  I also put my phone in my pants pocket and the signal was fine.  It seems that having the inline remote tucked against the head was limiting the signal and the signal improved a lot when the remote was allowed to hang free.  I decided to keep the X3's since I can now use them for the purpose I bought them for.  Maybe it's something that can be improved with a firmware or software update, but the connectivity for now is adequate.

    0
    Comment actions Permalink
  • bbrac

    @Eric Vierra Yes, thank you for the feedback. I will let our team know and see what can be done with future updates. Please feel free to share more feedback as you use the headset. I apologies for the inconvinience but thank you for giving us an update. 

    0
    Comment actions Permalink
  • stay_woke

    There have been large threads about this problem in the past. Why will Jaybird not just pin them to the top? Here is one:

     

    https://support.jaybirdsport.com/s/question/0D531000065MoqSCAS/connectivity-problems-with-the-x3s

     

    The bluetooth for the new X3 and JF5 sucks. Quality has gone down for sure.

     

    The X2 was definitely superior. It had better connectivity and water/sweat resistance. I can walk around with my phone in my shorts pocket and the connection barely dropped out, with the X2. The X3 would sound like a scratched CD. I even washed and dried the X2, by accident in a load of laundry, and they sound perfectly fine. Jaybird messed up with the new line. They use dumb charging dongles and inferior bluetooth components.

    0
    Comment actions Permalink
  • svth

    I´ve got the same problem. Out riding my bike I have my HTC One in my jerseys back pocket. appr 70cm from the X3.

    There is nothing in the way, just the thin nylon layer of my jersey.

    //Sven

     

    0
    Comment actions Permalink
  • Mjonesmb1
    I am on my 3rd pair of these and this has the the same issue as the last 2 pairs. They all had the exact same issue. I am so done with these. I want to return and just get my money back. Jaybird if your listening please let me know.
    0
    Comment actions Permalink
  • ScottByer

    bump

    0
    Comment actions Permalink
  • FlexM

    I also got mine replaced but same issue persist. It is a very poor product. I don't know if i could still use this in the gym.

    0
    Comment actions Permalink
  • Mjonesmb1

    FlexM yes it is very annoying, I am done and going to have to get something different. I contacted Jaybird about the issue and all they keep wanting to do is replace them. They will not give me my money back because I bought them at Best Buy, I even still have the receipt, and not through their site. I have talked to several people and the same story. So upsetting they will not just simply give my money back.

    0
    Comment actions Permalink
  • FlexM

    I changed my X3 fit from over the ear to under the ear and it works perfectly now.

    The bluetooth range is also increasing. Hence, the problem here is the design. I prefer more over the ear fit but since it has an issue then i will stick to under the ear design.

    0
    Comment actions Permalink
  • Madix
    same problem with the x3 intimitantly cuts out? choping the great sound or talking ?? bit disapointing for a quality product. Takes that edge off top buds. Cheers
    0
    Comment actions Permalink
  • DivineHoneyBadger

    I had terrible bluetooth reception on my X3, had to hold the phone in direct sight with remote about 30cm away to have a stable signal. I tried all the suggestions about that i found but nothing worked. Basically the earbuds were unusuable for me because the signal cut out on any small head movement.

     

    But i found a fix for my bluetooth problems. I do not know if this solves it for others, but i wanted to share this if someone is having similar problems since apart from the bluetooth problems those earbuds are fantastic.

     

    So what i did was to enhance the reception on the remote. So i just left the charger attached to the remote to see if this would help and i was quite suprised. The signal is very good now. The range went from 30cm to 5-10m. No more cutting off when the phone is in the front or backpocket, left or right. And the remote can now worn over ear as well touching the head.

     

    I know this is not the ideal solution, because the charger is not moisture proof, but at least i can use them without having to worry about the connection issues.

    0
    Comment actions Permalink
  • Hender13

    Jesus I thought I was the only one having this issue. I loved the X2 and that's why I upgraded to X3 but with this issue I'm forced to switch because there's nothing I hate more than this🙁

    0
    Comment actions Permalink

Please sign in to leave a comment.