Left bud won’t charge

Comments

2 comments

  • Bruce

    Hi ShoeSlayer,

     

    I am sorry to hear that your Jaybird Run XT's left bud does not charge in the case. This is not the quality we're expecting from our product.

     

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 2 hours only.

     

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris. 

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • ShoeSlayer

    I've read your copied and pasted answer before.

     

    Even if by some miracle I'm able to charge the left bud again, whats the deal with the bluetooth weakness.

     

    Constantly dropping stereo and playing from one ear or the other, cycling back and forth between ears. It's shocking.

     

    From a trouble shooting perspective, I removed the stabilizer wing from the left bud and placed it in the charger. It worked and started charging.

     

    However this means that I am unable to charge the bud while the wing is on it? I have to remove it everytime?

     

     

    0
    Comment actions Permalink

Please sign in to leave a comment.