Run XT left earbud will not turn on

Comments

3 comments

  • Logi_Bruce

    Hello TPip,

     

    I am sorry to hear that your Run XT's left bud won't turn on. This is not the quality we're expecting from our product.

     

    Kindly try using a different power source/charger and/or a different USB cable. A pulsing green LED on each side means it is charging, solid green light when fully charged. It is recommended to use 5V/500mA-1A charger for 3 hours only.

     

    It would also help to ensure that the lid of the charging case is securely closed and the charger ports and prongs align accordingly and are free from debris.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • TPip
    Hi there, Thank you but the left is still not working. Both lights are showing charge on case but only right ear bud light comes on when you push them both. They had both been working when I last used them on Saturday.
    0
    Comment actions Permalink
  • Lucas

    return them mate, they are clearly not functionning well and that's to be expected with jaybird... my x2 at the time were sweat resistant, still the left bud stopped working about about 4 months... check online you'll see many people think jaybird don't put enough quality checks before shipping their products; that's their biggest flaw aside from bad customer care (it's gonna be a pain in the ass to refund yours)

    0
    Comment actions Permalink

Please sign in to leave a comment.