My jaybirds won't pair anymore. Any trouble shoots?

Comments

2 comments

  • Bruce

    Hi Fabe,

     

    I am sorry to hear that your Jaybird X2's won't pair with any device. This is not the quality we're expecting from our product.

     

    Here is a list of steps for the Factory Reset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Hold both volume buttons for eight (8) seconds. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can further isolate the issue by testing using a different device or a device with a different OS.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Bmorerad

    Hey Jaybird_Bruce

    ?

    I'm having the same issue and have tried multiple factory resets, deleted the X2s from my phone's memory and ?still can't get my phone to recognize the headphones.

    ?

    The issue is not with my Motorola Droid--it still pairs with my truck, watch, gf's car, etc.

    ?

    Also, tried connecting my gf's phone to the X2s and got nothing.

    ?

    Please help!

    ?

    Thanks

    ?--Brad

    0
    Comment actions Permalink

Please sign in to leave a comment.