X2's randomly "stop" playing

Comments

12 comments

  • Engelbert

    Hi David,

     

    I'm sorry to hear that your Jaybird X2 stops playing. This might have to do with the bad connection that you are also experiencing. I can assure that this should be not the behavior and performance of the product.

     

    I've read your post and the only suggestion that I would like you to do is pair and test the X2 on a different audio source then check if the issue persists.

     

    Please post back for the results and I'll assist you further with it.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • David Puffer
    Thanks Egie. Happens on an Android tablet, surface Pro 3 and a Dell 4077 laptop.
    0
    Comment actions Permalink
  • David Puffer

    I hard reset my phone over the weekend and they are still "stopping". Have you actually tested these with Android phones such as the S8 or just assumed they'd work? This is infuriating to say the least.

     

     

    0
    Comment actions Permalink
  • Moises Ol

    I have had my jaybird X2 with this issue as well, I have already tried a factory reset on my phone as well as the actual headphones. Music plays just fine for a few seconds, music cuts out but music time is still going. After a few seconds the headset disconnects. The device Im using is an LG G5.

    0
    Comment actions Permalink
  • David Puffer
    @Moises Olvera Thank God I'm not the only one. It's infuriating and no one from jaybird has been able to give me a fix. I'm real hesitant to buy the X3s as I'm looking to upgrade.
    0
    Comment actions Permalink
  • MoisesOl25
    @David Puffer I too was thinking about getting the X3's but I mean for the price that these are sold for this shouldn't be an issue. I took care of mine, never dropped them and always put them in the case. After looking at the X3's I was scared that this issue would happen to those as well so I decided not to get them. Instead I baught the Sol Republic Relay Wireless. Ive had good history with them and those earphones are great. I would recommend looking into those. (Great bass and sound quality, sweat resistant, quick charging, great fit at least for me)
    0
    Comment actions Permalink
  • hendo305

    EXACT same issue. I also have an LG G5. The audio will stop playing... the only workaround that I have found is to press and hold the middle button until the google beep is heard, then hit the middle button again. That will at least get the music playing again for me. Major pain in the ass though. Sometimes I can get a few minutes of playback out of them, but quite often it happens every 30 seconds or so. Used to wear an android wear watch and the jaybird folks suggested that was causing interference, but I don't wear that at all anymore and the problem still persists. I wouldn't recommend these headphones to anyone.

    0
    Comment actions Permalink
  • dbeechey

    @Kris H? @David Puffer? @Moises Olvera? any solution to this issue?

    0
    Comment actions Permalink
  • David Puffer

    I actually got a pair of X3's for my birthday from my Dad this month. No issues with them yet but I still use my X2s as back up and they still crap out.

    0
    Comment actions Permalink
  • dbeechey

    This worked for me, for less than 24hrs that is...

    Settings > Battery & Power Saving > Battery Usage > Ignore Optimizations > Turn on for both Bluetooth Options and Bluetooth MIDI Service > Restart phone

     

    Next day issue started happening again!

     

    Went to Apps > Show System > Bluetooth > Storage > Clear data and did the same for the other Bluetooth app and Bluetooth MIDI Service. It seems to have worked for a few minutes but back to music cutting out and then connection eventually dropping again...

    0
    Comment actions Permalink
  • Sabar

    I seem to be having a similar thing happen to me. My headset is about 7 to 8 months old and suddenly developed a problem. For some reason mine will stop playing, however what ever player i am using either Audible, or music player says it is still playing and the phone says the headset is still connected. then about 30 - 60 seconds i hear the tone that headset has disconnected from the phone (Samsung S7 Edge). I then reconnect and it plays for another 15-20 minutes before it all happens again.

    0
    Comment actions Permalink
  • dbeechey

    I'm using and LG G5 and the X2s and had similar issues with music/connection dropping intermittently.

     

    I found that the issue, in my case, appeared to be related to the Android Wear app on my phone trying to connect my LG G Watch when either the watch wasn't around or the battery had died. Now when I don't have my watch around I have to go in to the Android wear app and manually turn off the connection to the watch.

     

    Since I started doing this I haven't had problems with the X2s disconnecting or music stopping.

    0
    Comment actions Permalink

Please sign in to leave a comment.