My X4 will not connect to the Jaybird app. It just sits on 'Scanning' forever. It pairs to the phone fine. I have deleted the app and reinstalled and unpaired and repaired the X4's. Can you help? iPhone 7 Plus, IOS 12.0

Comments

4 comments

  • Logi_Bruce

    Hello Rocko99,

     

    I am sorry to hear that your Jaybird X4 cannot connect to the Jaybird App. This is not the quality we're expecting from our product.

     

    Please try the following to resolve the issue of your headset:

     

    1. Turn off bluetooth for at least ten (10) seconds.

    2. Turn it on using iOS Control Center instead of Settings. The Bluetooth button is at the top left of the screen and you can access the Control Center by swiping up the bottom of the screen (swipe down from top right on iPhone X).

     

    Feel free to reach back to us via your support ticket or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • vgcrepairs

    I had same issue, but just keep power cycling them and it finally connected on iPhone with IOS 12

    0
    Comment actions Permalink
  • gingerandoat

    This happens to me today, for my new X4 I got yesterday. It worked find yeaterday until afternoon today. Right now (18:00) the device is not detected by my iPhone X despite of numerous attempts on/off of the X4 and iPhone X. Please help

    0
    Comment actions Permalink
  • ALEH

    I am also experiencing this same issue. My new headphones that I got on Friday worked all weekend and then this morning they are not able to connect. I did the hard reset and also restarted my phone and nothing. I also validated that my phone could connect to other bluetooth devices.

    0
    Comment actions Permalink

Please sign in to leave a comment.