My X2 is not turning on even after attempting to reset

Comments

14 comments

  • Engelbert

    Hi tweishen,

     

    It is sad to hear that your Jaybird X2 does not power ON. I'll be glad to help you with the concern.

     

    Please try the factory reset that can help resolve the issue. This is a different one compared to the instructions stated from our support website.

     

    1. Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    2. When finished, plug the headset into the charger for 2.5 hours and check the color of the LED status lights.

    3. Power ON the device by holding the power button for 10 seconds or more.

     

    NOTE: Most of the time if the headset turns RED, it will charge and function normally again. Make sure to fully charge the headset when the light is red.

     

    Also, try charging the Jaybird X2 with a different USB cable and power source.

     

    Hope this helps.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • jerome7_7

    Hi I didnt use my jaybirds for quite a few months. Yesterday i wanted to use it so i took it from its case and charged it, knowing it would'nt have any charge left. Charging it the charging indicator was green instantly. unpluging it and plugging it again it turned from red for half a second and ws green all the while. I tried the hard reset of 8times press and 9th time hard press 'several times'. But it wouldn't turn on. Everytime i charge it after the hard reset steps, the indicator still turns green and not red :((( Kindly help resolve my issue. Thanks in advance

    0
    Comment actions Permalink
  • M_P

    I have exactly the same issue as jerome7_7. It started one week ago and no reset process or the "8 button process" helps.

    0
    Comment actions Permalink
  • Carlos03

    Same here

    0
    Comment actions Permalink
  • Daveklingman

    And I am also in the same boat...

    0
    Comment actions Permalink
  • Miquel888

    This reset process (power button 8 times, with 5 second hold, two times) does not work. My LED status light is still GREEN.

    0
    Comment actions Permalink
  • rebischung

    Hi, I also got this issue. It stopped when I pushed the button for stopping music. I tried to charge them (green light) and also the process to get the factory reset. But it still doesn't work. Pushing the button doesn't appear to work anymore. Any advice ? Thanks

    0
    Comment actions Permalink
  • enocli

    I have the same problem. I've been using my X2s for almost 2 years and would suck if they stopped working :(

    0
    Comment actions Permalink
  • dveder

    same here. no support from jaybird at all. never buying jaybirds again!

    0
    Comment actions Permalink
  • enocli

    I had the same problem but I called jaybird support and they very kindly replaced my pair for brand new X3s! Customer support was super fast, simple and nice.

    0
    Comment actions Permalink
  • bocufo

    Same problem, no reply from jaybird support. Reset doesn't work. Think I'm done with Jaybird also.

    0
    Comment actions Permalink
  • Wave181

    I to have the same problem and posted the question a couple of weeks ago. NO REPLY FROM JAYBIRD!!!!!!!!!

    There obviously is a problem with the X2 and Jaybirds lack of response is deafening!

    Very disappointed...if there is no response I will reconsider my future purchase of a Jaybird product

    0
    Comment actions Permalink
  • Miquel888

    I finally tried customer service like enocli wrote about on 10/10/17. I called 1.866.244.3399 and customer service was outstanding. I am getting an X3 to replace my X2, and the process was really easy-no shipping the old pair-just emailing proof of purchase and two pictures. My X2 were 17 months old and Jaybird is replacing, no problem.

     

    Way to go with customer service Jaybird.

    0
    Comment actions Permalink
  • Juank

    Señores Buenas, tengo un X2, me habían funcionando estupendamente, siempre hago deportes con ellos, pero se me presento el problema que se mantienen encendidos y mientras los equipos están enrutados con ellos no hay problema, pero no suben volumen ni lo baja, no me sirven los mandos, no se apagan, toca esperar a que la batería se agote, no se alguien me puede ayudar ya que son excelentes para todas las actividades deportivas ayudaaaaaaaa

    0
    Comment actions Permalink

Please sign in to leave a comment.