Can't turn on my Jaybird X2

Comments

8 comments

  • Madi

    Hi there!

     

    Sorry to hear about the issue you're experiencing with your X2s. I recommend that you contact our Customer Experience team so we can provide further support for you. You can reach out via live chat, email, or phone (1.866.244.3399), we look forward to helping you out with your X2. 

     

    - Madison

    Jaybird Customer Experience 

     

    #poweryourpassion

    0
    Comment actions Permalink
  • Armando5617
    I have the same problem... How long do they take to answer an e-mail?? 🙁
    0
    Comment actions Permalink
  • watsky

    Armando5617 you should call them because they will give you some sort of resolution immediately.

    0
    Comment actions Permalink
  • Derek1417

    Hi Madison,

    I am from Singapore and had a similar problem, bought my unit from Amazon on 31 Oct 2016. Contact Amazon customer service and was given this link.

     

    My unit will not turn on when I depress the power button but if I hold it down longer, it will prompt me "connect..., connect...., connect....." It seems to be prompting me that it is connecting but the voice will just fade away.

     

    Can you help me to create a case for a return/replacement.

    0
    Comment actions Permalink
  • BurgerKing

    I have the same problem....

    0
    Comment actions Permalink
  • sa155404

    same problem - this site is littered with the same problem...

    0
    Comment actions Permalink
  • CZ201682
    I had this problem too. Jaybirds were fully charged but would not turn on. I left them off the charger and let the battery run down completely. This will take several days. I charged them back up and they are working perfectly again. It's worth a try.
    0
    Comment actions Permalink
  • sa155404
    Trying that, thank you. Thing is sometimes the lights are on, sometimes not. if i switch of my iPad and delete JB on the BT list it can reconnect and work (without the charging unit). Then when i switch songs it fails again...but works when the charger attached. Bizarre. Anyway, i'll post the results ...
    0
    Comment actions Permalink

Please sign in to leave a comment.