I can not turn on my jaybird x2 anymore.. Plug in the charger, LED on the buds showing green. Try reset procedure does not seems to react.

Comments

45 comments

  • bbrac

    @Yingran Duan Have you tried this 8x reset?

     

    Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

     

    When finished, plug the headset into the charger and tell me what you see.

    Most of the time if the headset turns RED it will charge and function normally again, Make sure that if the light is red to fully charge the unit again.

     

    Try holding the power button down for 10 seconds also some times it takes longer to turn them on.

    0
    Comment actions Permalink
  • yingran

    yes, I did try the 8x reset. Plug the headset into the charger after, and I saw green light on the buds.

    0
    Comment actions Permalink
  • bbrac

    @Yingran Duan I just created you a case, please reply to that email for further help. 

     

    0
    Comment actions Permalink
  • Calvinjap
    Hi Beau, have this issue been resolved for Yingran? I am having the same trouble, have attempted the 8x reset to no avail, can you advise? Thank you.
    0
    Comment actions Permalink
  • waxMD

    I'm having the same problem as well, with my X2...charging it and you can just see the green light on...unable to reset it as advised. 

    Help please...

     

    0
    Comment actions Permalink
  • angelface1007

    @Beau Brace  What exactly is the 8X reset procedure?? I bought mine new June 2016 and never used it until this year when I re-found it in my house. My X2s from 2015 work just fine but these 2016 ones are not working as mentioned above!  How do I submit a ticket then?  I bought them on Amazon and it's past the return time window now. What are my options? 

    0
    Comment actions Permalink
  • kristalama

    Having exactly the same problem. Tried resetting to no avail. Has this worked for anyone?

    0
    Comment actions Permalink
  • sment

    I also have similar problem. Please help!

    0
    Comment actions Permalink
  • NewbeeHarmOne

    I have exactly the same problem; my Jaybird stopped working. I had applied the X8 reset procedure and nothing happens. I also open the case # 04962355. Any help will be appreciated, as the 1-year warranty limit is pretty close!

    0
    Comment actions Permalink
  • GorillaSkinz
    Mine are doing the same thing, has anyone found a fix? 8x Reset will not work, always shows a green light.
    0
    Comment actions Permalink
  • Gatot
    Hai.. i have the same issue.. cant power on my x2??
    0
    Comment actions Permalink
  • iceteague

    same problem.

    0
    Comment actions Permalink
  • Joasia

    I am having the same problem. Is there a solution? The reset did not work for me either.

    0
    Comment actions Permalink
  • tnhansel

    have the same problem since last week, tried 8x reset to no avail. This is a very well known problem with the X2. Contacted customer service and they offered me a replacement Jaybird Freedom instead. The customer service response time is ridiculously long, be mindful...I am still waiting for the customer rep to reply my email (one reply every single day, at max 2 replies from them in a day)

    0
    Comment actions Permalink
  • NewbeeHarmOne

    In my case, Customer Support offered my a Freedom as a replacement, as I was still on the warranty period. The response time was pretty good as well as sending the replacement, but this requires several interactions in order to verify the X2 is indeed not working.

    0
    Comment actions Permalink
  • hamzaalvi

    I need to know how did you contact the customer service NewbeeHarmOne. I'm having the same issue with my X3. I've only had them for 4 months. I need a replacement too. I've written them an email but so far there hasn't been a reply.

     

    I bought them from eBay, and took them out side of US where I live. Do you have any idea how can I get my warranty to work and get them to verify that they indeed aren't working.

    0
    Comment actions Permalink
  • RobHolley

    Just wondering if anyone actually found a solution to this? My Jaybirds have just stopped out of nowhere.

    0
    Comment actions Permalink
  • sepehr3pehr

    I have the same problem.

    0
    Comment actions Permalink
  • RobHolley

    Right or wrong, I've finally been able to fix my Jaybirds. Not sure what the kicker was, but it was only after all of the following did it kick back into life.

    ?WARNING: My Jaybirds are 2 years old and out of warranty so I had nothing to loose.

    ?

    ?1. Opened the control housing around the buttons and cleaned any dirt and reset the buttons. (I found a post regarding the power button not working properly)

    ?2. Pressed the power button 8 time very fast then held it for 5 seconds.

    ?3. Repeated step 2

    ?4. Put them on charge until the green light displayed

    ?5. Held the power button for 10 seconds

    ?

    ?I don't have much faith that they will stay fixed but for the time being I'm not having to think about buying some new headphones.

    0
    Comment actions Permalink
  • bfhd

    I was able to temporarily fix my X2s with the 8x reset procedure - but I had to try it several times. I also pressed the buttons lots of times very firmly (in frustration!).

    They would turn on once, but haven't since then.

    0
    Comment actions Permalink
  • jcdiego

    Don't buy Jaybird products. I've had two replacements have the same power issues and won't turn on even though the power light is green when plugged into the charger. Not worth the money!!!

    0
    Comment actions Permalink
  • RobHolley
    I'm convinced the issue lies with the circuit board contact with the power button. Took mine apart after the initial fix regressed. The constant firm pressing in anger must have moved the contact and the button wasn't registering a press. Would appear that the headphone thinks you're holding the power off. I believe this has anything to do with the battery at all. Either way very disappointing. Only problem with not getting anymore Jaybirds is that the rest of the Bluetooth market is poor for what I use them for. Finger cross on the X4 if they ever appear.
    0
    Comment actions Permalink
  • Patrick Boston

    This is the slippery slope Jawbone went down, and down, and down....... Poor service and poorer products. Actually let me correct that, no service at all. The only quality I can see in the earbuds I purchased is the packaging. Now that is a company I will invest in.

    0
    Comment actions Permalink
  • Spadak

    Well mine like many of yours have gone into the dead dead dead state.  Green LED when charging but will not for the life of me turn on.  Did the 8X trick worked for an hour, but now I can't get them to power on at all.  No good for such an expensive set of headphones.  I emailed customer support to see if maybe they could help, will update the group if I get any response.?

    0
    Comment actions Permalink
  • jaybirdnewbie

    Mine just gone as dead this morning. Tried to plug and unplug from the charger, worked for whole morning, but is acting up again in the evening. It suddenly turned off by itself during my listening to music.

     

    tried to browse to other thread and someone suggested hard reset by turning on your headset (if it still turns on), and when the light is green, immediately press both the up and down volume simultaneously until the light turns orange and flashing 3 times.

    Then try to unpair and pair again with your device.

     

    Works for the time being.

    Lets see if it actually works and not just for a moment.

    0
    Comment actions Permalink
  • lt_dan45

    My X3 is suffering the same issue only a month after using. Nothing I do seems to work and customer service is unresponsive to any of my inquiries :(

    0
    Comment actions Permalink
  • Zer0Gee

    My second set is acting the same, after 7 weeks of full pleasure. Previous set only lasted 4 weeks. Exactly the same behaviour as described : no more powering on, charging immediately turn the green LED on, 8x reset trick doesn't help. Very very frustrating. And disappointing.

    0
    Comment actions Permalink
  • beat@X2

    @Robert Holley? : You are great man!! Bang on! Your 1st solution worked. Thanks for your help.

    Below are the steps I followed to brings the beats back to my JX2.

     

    ?1. Opened the control housing around the buttons (be gentle as wires inside the housing are delicate)

    2. Used alcohol swabs to clean the dirt and grease inside the control housing and switch contact points

    3. Reset the buttons, tested the power on button and heard the sweet voice saying..."Power on"

    4. Replace the control housing to its original form and for extra protection use a good quality insulating tape around the housing.

     

    ?Warning: My Jaybirds are 3 years old now and out of warranty.

    0
    Comment actions Permalink
  • dada1009

    same here, i tried the reset method, saw green button but when unplug it just simply won't turn on... any other tricks to power it up again? i live in Hong Kong so cannot find any store support here

    0
    Comment actions Permalink
  • Missoula Magoo

    i think the answer is clear. We all made a bad choice in buying these. Cut our losses and move on. Customer service is nonexistent

    0
    Comment actions Permalink

Please sign in to leave a comment.