My x2 doesnt turn on

Comments

38 comments

  • bbrac

    I am sorry to hear about your headset. Do you get any LED lights at all when plugging the headset into the charging cable? 

    0
    Comment actions Permalink
  • Dani35

    My x2 neither turn on, whats happen?

    0
    Comment actions Permalink
  • Mmulder

    I have the same problem. Bought mine in July through Amazon, and it would not turn on after 2 months usage. And Jaybird Support still have not reply.

    0
    Comment actions Permalink
  • bbrac

    What color LED lights show up when plugging the headset into the cable? Maybe try the reset below to see if that helps, also try using a different power source. 

     

    Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    When finished, plug the headset into the charger and tell me what you see.

    Most of the time if the headset turns RED it will charge and function normally again, Make sure that if the light is red to fully charge the unit again.

    Try holding the power button down for 10 seconds also some times it takes longer to turn them on.

    0
    Comment actions Permalink
  • Mmulder

    Nope, didn't help at all. It still does not turn on.

    0
    Comment actions Permalink
  • Mike1300

    Similar issue here. I get the red and green (charged) LED without issue when plugged into an outlet. I do not even try a laptop USB port to charge. In any case, the reset did not work. Looks like I will have to find the receipt and call in to a person to discuss.

    0
    Comment actions Permalink
  • JaxA92

    I get a red light that randomly turns green and then back to red again. There is a short second or two where the light goes off altogether. 

    0
    Comment actions Permalink
  • MattSorich

    I've been struggling with issues like this for years now with my Jaybirds X and X2s.  Unfortunately, the RMA process requires you to pay shipping cost to send dead unit back.  On top of that, you are without headphones for a week or so.  

    0
    Comment actions Permalink
  • mcjones1969

    I am having the same issue, I did the reset steps listed above and they did not work either

    0
    Comment actions Permalink
  • bbrac

    Okay, I created you a case and sent you an email. Please respond back to that email for further communication. 

    0
    Comment actions Permalink
  • Totalshot
    @Beau Brace I guess a lot of people are having an issue with x2. ??
    0
    Comment actions Permalink
  • gareth newcombe

    Me too, same issue with power on. Seams to forget they have charge after powering off. 

     

    Any fix yet?

    0
    Comment actions Permalink
  • bbrac

    @gareth Newcombe Have you tried other power sources or charging outlets? Also have you tried the 8x Reset?

    0
    Comment actions Permalink
  • x2owner

    @Beau Brace I bought my X2 6 months ago.  I have the same problem as others.  It no longer turns on and the light is solid green when I plug it into my computer.  I've tried the 8x twice reset and a different reset i saw online (hold volume up and down simultaneously).  I've tried charging on a home desktop, laptop and a work desktop with no luck.

    0
    Comment actions Permalink
  • jlevitt

    UPDATE: Beau from Jaybird contacted me and has provided an acceptable resolution. It appears my poor experience described below was isolated. Great to see Jaybird is still committed to their products!

     

    Get your money back and run from this company. They used to be great, standing behind their product. However, Jaybird was acquired by Logitech this year.

     

    I had three (!!!) pair of X/X2's with each failing as you describe. Jaybird promptly replaced the units each time one failed (obviously a known issue situation). 

     

    When my third pair stopped working recently, I ran into a cold support system. They claimed the wouldn't replace my defective product because the warranty on the ORIGINAL unit had expired and they provide no warranty on replacement units (ref # 04380526).

     

    There are many great alternatives available on Amazon now ... many at 1/3 the price. Get your money back and buy from any other company than this. So sad to see the decline of a once potentially strong brand.

    0
    Comment actions Permalink
  • bbrac

    @Albert Brick I just sent over an email to help you further. Please respond to that case.

    0
    Comment actions Permalink
  • Cheong
    @Beau Brace Suddenly my X2 turned off when I'm doing gym workout so I charge it for overnight and the next morning the X2 can't be turned on. @Beau Brace , any solution? Thanks
    0
    Comment actions Permalink
  • bbrac

    @Sheau Wah Cheong Have you tried the 8x reset below?

     

    Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

     

    When finished, plug the headset into the charger. Most of the time if the headset turns RED it will charge and function normally again, Make sure that if the light is red to fully charge the unit again.

     

    Try holding the power button down for 10 seconds also some times it takes longer to turn them on.

    0
    Comment actions Permalink
  • name_is_nick

    @beau I have the same problem x2owner. Bought mine from Amazon on 14/Oct; they no longer turn on and the light is solid green when I plug it into my computer or wall charger. I've tried the 8x, then 5s reset already. No luck. Please advise.

    0
    Comment actions Permalink
  • bbrac

    @Peter Henriksen Okay I also created you a case. Please respond to that case so that I can help you further. 

    0
    Comment actions Permalink
  • name_is_nick

    @beau - thanks for the quick response. I have responded to the case in e-mail.

    0
    Comment actions Permalink
  • bbrac

    @Peter Henriksen No problem at all, I am happy to help. 

    0
    Comment actions Permalink
  • Big Albie
    @beau same problem and have used the 8x reset with no luck. Always shows green light so not sure why it's not working. please advise
    0
    Comment actions Permalink
  • bbrac

    @Alberto Amiana I see that Madison created a case for you, please respond to that case for further help. 

    0
    Comment actions Permalink
  • Cheong
    @Beau Brace i just try the restarts is work and yesterday the earphone keep redialling and redialling and power off. Please advise
    0
    Comment actions Permalink
  • Knowlerstyle
    @Alex Boyle hello sir I am having the same issue of my buds not turning on. I bought them about three months ago and now they will not turn on. Tried the 8x reset about five times and no burnout. I bought them from the bx in Germany but now can't replace them due to lost receipt. Please help me get these things fixed.
    0
    Comment actions Permalink
  • bbrac

    @Sheau Wah Cheong Have you tried this reset? 

     

    During the pairing mode ( red / green ) it is possible to reset your headphones. First follow the steps to enter pairing mode. By powering up the headset, holding past the ( green ) led light till you receive the multi color flashing.  Then instantly switch and hold the up & down key simultaneously until the dual color status indicator LED rapidly flashes 5 times and or a double high tone is heard threw the headset.

     

    You'll want to delete & repair the headset to your music player once finished with that.

    0
    Comment actions Permalink
  • jayhodges

    My X2s announced they were low on power.  I turned off and plugged into a charger.  The green light came on immediately indicating a full charge.  I removed from the charger and attempted to turn ON.  The power light would not come on and the headset was definitely not ON.  I plugged back into power with the same result, an immediate green light.  Remove from power, won't turn ON.

     

    I executed the the 8x reset with no apparent affect.

    0
    Comment actions Permalink
  • bbrac

    If the resets above did not work, please reach out to our support team so that we can help with an exchange. I will list the link below to where they can be contacted. I do recommend our chat feature. 

     

    http://www.jaybirdsport.com/support/

    0
    Comment actions Permalink
  • This happened to me after using them twice. Doing a quick search on youtube, it seems like this is a really common problem. Just throwing that out there. It won't go into pairing mode, so I guess I need to deal with trying an exchange.

    0
    Comment actions Permalink

Please sign in to leave a comment.