Will these older generation models work with the app from the play store? When I try to pair them via the app, it says it cannot find them, but when I pair them through my note 8 bluetooth settings it will pair and I can use them.

Comments

1 comment

  • Bruce

    Hello M-,

     

    Thank you for sending your query. I will be more than happy to help.

     

    Jaybird Models that are from 2015 and older cannot be connected via the app, this includes Jaybird X2, Bluebuds X, Freedom Sprint 3 and 4, etc. You can however, connect them via bluetooth.

     

    For 2016 and newer, you can use the Jaybird App as well as bluetooth. This includes Jaybird Freedom, X3, Run and Freedom 2.

     

    I hope this answer helps with your query.

     

    Please feel free to reach us back by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warmest Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

Please sign in to leave a comment.