Freedom Sprint won't charge

Comments

3 comments

  • Engelbert

    Hi svitosh,

     

    I'm sad that your Freedom Sprint will not charge. I'll be glad to provide you the steps on how to perform an 8 button process that can help resolve the issue.

     

    Please follow the steps below on how to do the 8 button process.

     

    1. Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    2. When finished, plug the headset into the charger for 2.5 hours and check the color of the LED status lights.

    3. Power ON the device by holding the power button for 10 seconds or more.

     

    NOTE: Most of the time if the headset turns RED, it will charge and function normally again. Make sure to fully charge the headset when the light is red.

     

    Feel free to post back for any other concerns or questions.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • Katy

    Hi @Egie,

    I tried this and now my LED lights are alternating red and blue. This happened when I tried two different times to do the 8-button process.

    0
    Comment actions Permalink
  • AntonioSolares

    Hello

     

    I got the same issue, i already do the procedure, but for me doesn´t work...

     

    any other suggestion?

     

    best regards

    0
    Comment actions Permalink

Please sign in to leave a comment.