Sound only coming from one headphone

Comments

3 comments

  • Logi_Bruce

    Hello AMD102,

     

    I am sorry to hear that one side of your Jaybird X3 stopped working. I can assure that this is not the behavior and performance expected from the product. Please try these troubleshooting steps that can help to resolve the issue of your headset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can also check the voice prompts, if it play on both sides of the earphones.

     

    Feel free to reach out back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • AMD102
    I tried this several times and still nothing. The sound is still only coming out of one side.
    0
    Comment actions Permalink
  • Logi_Bruce

    Hello AMD102,

     

    Sorry to hear that it did not work. I created a support ticket for you. Please expect an email from us regarding this.

     

    Feel free to reach out back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink

Please sign in to leave a comment.