The Left ear bud on my Jaybird Run stopped charging. Besides cleaning the connections, does anyone have troubleshooting tips?

Comments

13 comments

  • respa

    Hi Epatermo,

     

    Thank you for posting here in the community. I am sorry to hear that the left earbud of your Jaybird RUN stopped charging. This is not we expect from our product and no worries, I'll be glad to help you out with this.

     

    A support ticket will be created to your account and expect for an email from one of our Jaybird Representative anytime within the day.

     

    Feel free to reach us back by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Best Regards,

    Jaybird_Axel

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • VS187952

    I'm having the exact same issue. Please help.

    0
    Comment actions Permalink
  • Jhoeps831

    same here...

    0
    Comment actions Permalink
  • Entrerri

    Has anyone found a better answer to this? I tried updating firmware and it's up to date.....yet still having connection issues. I have 13 more days to figure it out before I return

    0
    Comment actions Permalink
  • HeatherMStephen
    I am having the exact same issue! Have been for a few weeks, thought it was something with the charger I was using but this is SO FRUSTRATING
    0
    Comment actions Permalink
  • Kong Vitalium

    This seems to be a common problem. I have the exact same problem.

    Is there any easy fix, or should i turn them in for service?

    0
    Comment actions Permalink
  • Epatermo
    Jaybird did a great job initially trying to troubleshoot my issue - unfortunately without success- and then quickly offering a replacement unit. Their customer service was excellent to work with. Fingers crossed this pair is flawless. So far after one month they work great.
    0
    Comment actions Permalink
  • dtertius

    Hello,

     

    I have the same problem here, any firmware update to fix this issue?

     

    Tks

     

    Tertius

    0
    Comment actions Permalink
  • alihay

    same problem dont buy this product is very veryy BAD

    0
    Comment actions Permalink
  • Kong Vitalium

    @ali haydaroglu? nope. I cant agree. Mine fixed themselves and I can honestly say that it is the best headset I’ve ever had.

    0
    Comment actions Permalink
  • Camyt

    I just bought these after Christmas. Used them once and can see the green light from the left ear bud doesn’t charge. I have also noticed the left ear bud drops out of its blue tooth connectivity if you turn your head while running. Has anyone else experienced this?

    0
    Comment actions Permalink
  • jwalk72

    unfortunately my left earbud has stopped charging all together. It's unfortunate that someone from the Jaybird support team has not jumped in. Love the product but the support leaves much to be desired.

    0
    Comment actions Permalink
  • JiBow

    So the same thing happened to me. Left side stopped charging. So I read on here somewhere that one person took them out. Turned off the right side. Then held it down for 6 secs to turn on the Bluetooth and then put them back in the case. Weird. But I tried it and it 100% worked.

    0
    Comment actions Permalink

Please sign in to leave a comment.