Are you ever going to fix the windows 10 driver issue? I have updated to latest firmware but still cant get my x3's working on my windows tablet... frustrating

Comments

2 comments

  • Bruce

    Hi Marleymdw,

     

    Thank you for joining the community and for posting your query. I can definitely help you with this one.

     

    Sorry for any confusion, there are no issues connecting Jaybird X3's with a Windows Tablet.

     

    You can try resetting your X3's. Here is a list of steps for the Factory Reset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green. 

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset. 

     

    You can further isolate the issue by testing using a different device or a device with a different OS.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Marleymdw
    Yes there is an issue with x3 and windows, its even in your forums!!!!! See pic below for when trying to pair the Microsoft_HFP_Audio_Device_97 driver will not instal correctly, this prevents the headphones from connecting as an audio device Also here is the forum notes I mentioned saying this exact issue was fixed with firmware when its not https://support.jaybirdsport.com/s/question/0D53100006AK2MwCAL/jaybird-driver [cid:image001.png@01D4EF93.063C8ED0] Cheers, Martin Wynn
    0
    Comment actions Permalink

Please sign in to leave a comment.