Left side of my headphones are not working

Comments

4 comments

  • Boobus

    Similar issue, except mine is the side with the controls. Sound is much weaker no matter what buds I use or what angle they are in my ear. Just started happening after 6 months of use.

    0
    Comment actions Permalink
  • Dave1960

    Exactly same issue with mine left side zero sound only 3 months old. Bought in Digital Walker. The Philippines. ?This is the Serial No 1745SD107HZ8

    0
    Comment actions Permalink
  • Bruce

    Hi SazMusic, Boobus, Dave1960,

     

    I am sorry to hear that your Jaybird Freedom 2's left bud is not working. This is not the quality we're expecting from our product.

     

    Here is a list of steps for the Factory Reset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can further isolate the issue by testing using a different device or a device with a different OS and checking the voice prompts if it plays on both sides.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Boobus

    Thank you for the reply, Jaybird_Bruce. I did the reset process you outlined. I went to my Bluetooth settings, forgot the existing Jaybird device and they paired again easy. However, the side with controls still has severely lower sound output. I paired them with my friend’s android device and same results. I changed the war gottings and also inspected the bids to ensure there was no blockage or something clogging the connection. It’s clean/clear, anything else we can do to get this corrected?

     

    I also played with putting the cord at cord at various angles in case that would get the sound to come through at the same volume as the other bud. No luck.

    0
    Comment actions Permalink

Please sign in to leave a comment.