Freedoms Won't Turn On

Comments

14 comments

  • Engelbert

    Hi Ethan819,

     

    I'm sad to hear that your Jaybird Freedom does not power ON. I'll be glad to help you with the concern.

     

    Please try the factory reset below that can help with the concern.

     

    1. Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    2. When finished, plug the headset into the charger for 2.5 hours and check the color of the LED status lights.

    3. Power ON the device by holding the power button for 10 seconds or more.

     

    NOTE: Most of the time if the headset turns RED, it will charge and function normally again. Make sure to fully charge the headset when the light is red.

     

    Also, try charging the unit using a different micro USB cable and power source.

     

    Hope this helps.

     

    Warm regards,

    Egie

    0
  • SLYPANDA

    ETHAN,

    Did this work? Mine just did the same thing yesterday and I haven't been able to turn them on 

    0
  • NiiQuaye

    the problem was from their own UsB CABLE. I changed mine and used my androids USB, it lights now 

    0
  • Thadd

    Just bought my Freedom's a week ago and now can't get them to turn on even after following directions for hard reboot/factory reset above. Same thing happened to my last pair - but after two years. I plan on taking back today. It's my fourth pair of Jaybirds and now last three have become defective in shorter time period. Love product. Not performance and durability.

    0
  • hs333

    I have the same problem with my Jaybird Freedoms. Charging is perfectly fine and normal. Charges and light is red, and turns green when charged. However, it seems that the power button is faulty. Even though it is fully charged it just will not turn on. No sound or light indication to confirm it working, and they have been working fine for months. Why know the power button does not work, I do not understand.

    0
  • hs333

    now*

    0
  • ArchieMad

    Same problem. LED shows green after a full charge. Tried the above - it wont turn on. Tried with the usb cable while charging - it wont turn on. Tried it without cable - it wont turn on.

     

    Before it completely turned down on me, i experience several instances of it turning off while im on spotify.

     

    0
  • alex2go

    Same thing it just dont turn

    0
  • tEdgar

    Having the exact issue. By the way, this is my second set of Jaybird Freedoms with the same issue.

    0
  • abe.

    posted this same question. why suddenly won't turn on?

    0
  • molerk

    my jaybird freedom set stopped working this week. green light is on when charging - won’t hold a charge. this is my second pair that has died due to battery not holding a charge. at $100 per year for a new pair, this is not a good investment.

    0
  • Bradley8163

    Hello, I did a firmware upgrade a few days ago (because the app told me to) and now my Freedoms won't power on. I've tried this press 8x and hold 5 seconds routine, but they still won't turn on. Seems like the firmware update is to blame. I need help to get them back running.🙎

    0
  • Bradley8163

    UPDATE: I re-ran the firmware update (version 1.4.1) and this resurrected my Freedoms. I recommend it as a possible fix! 😂

    0
  • Suna Miller

    I got mine working again by doing the following as mentioned on the update firmware page.

    "If your buds are unresponsive after a successful update, put them back on the charger (connected to a power source) for a few seconds and then remove again. This will get them out of the unresponsive DFU mode after the update."

    I just turned mine on a second after I plugged them in to charge. They are back to normal and working.

    Best of luck.

    0

Please sign in to leave a comment.