I bought my Jaybird X3s about 4 months ago new and recently, the right side stopped working. I am very disappointed as I had saved up to buy and expected them to last at least a year of day - to - day use. Is there any way to repair the cable?

Comments

3 comments

  • Bruce

    Hi jhwang260,

     

    I am sorry to hear that your Jaybird X3's right bud stopped working. This is not the quality we're expecting from our product.

     

    Here is a list of steps for the Factory Reset:

     

    1.Make sure your buds are powered off.

    2.From an off state, press and hold the power button for 8 seconds until the LEDs flash red and green.

    3.Double press the power button. The LED will flash rapidly and you should hear a double tone. Your buds have now been reset.

     

    You can further isolate the issue by testing using a different device or a device with a different OS and checking the voice prompts if it plays on both sides.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

  • jhwang260
    Hi , I have tried these things and the reset and device switching did not work. YiS Joshua Hwang
  • Steveoconnor

    Can you use the other ear bud if the right side is broken ? I just want to return them for new ones. My buds broke in my ear and had to use a magnet to get them out.

Please sign in to leave a comment.