"Headphones Connected" repeatedly plays when connected to 2 devices

Comments

20 comments

  • bbrac

    @Jacob Wanous Does this happen when you are switching between devices using multipoint? 

    0
  • Metamyr

    @Beau Mersereau I don't think so, I'm not doing any sort of manual switching.  It just happens when I'm paired to both devices at the same time.  It looks like it's briefly disconnecting and reconnecting from the Android phone (the MySound notification will briefly disappear and then reappear as it's happening).

    0
  • Metamyr

    This also only appears to happen when the Macbook is the active device on the earbuds.

    0
  • bbrac

    @Jacob Wanous Try this hard reset and let me know if that helps. 

     

    To reset your Freedom buds to their original factory settings, put your buds in pairing mode by turning the buds off then push and hold the center button for more than 4 seconds until you see alternating red/green LED. 

     

    While the LEDs are flashing red/green double tap the center button. Upon successful party reset, the LED turns orange and your buds turn off. 

     

    NOTE: Once your buds have been reset and you power on they will automatically go into paring mode. Select “Forget” or “Remove”  Jaybird Freedom from your device’s bluetooth menu and pair again.

    0
  • Metamyr

    @Beau Brace  Same behavior after the hard reset.  Do I need to do anything special when pairing for use with multipoint?  Or just go through the standard pairing process for both devices?

    0
  • bbrac

    @Jacob Wanous Correct, just go through the same pairing steps as normal. 

    0
  • Metamyr

    @Beau Mersereau  Any other ideas for a fix?

    0
  • bbrac

    @Jacob Wanous Have you downloaded the recent app update? If so, please connect the headset to the app and then reset the headset so that the update will take place. Then let me know if that helps. 

    0
  • Metamyr

    I have the most recent version of the app available from the Google Play store (1.5).  I did another factory reset on the headset and the issue persists.

    0
  • bbrac

    @Jacob Wanous I am sorry that we could not get this to stop happening. I do not have any other TR's to try. If you could please send an email, chat or call into the link below. We can have an Agent set you up with a warranty claim. 

     

    http://www.jaybirdsport.com/support/

    0
  • Kill_dano
    I'm also having this issue. I've had it since I bought them. It's kind of intermittent. I have a note 5 and a shield tablet. When connected to both, sometimes they keep saying headphones connected every minute or so. Also the function of switching between them automatically seems to be broken. The connection gets stuck on a single device often
    0
  • DT381

    I'm having the same issue, though less frequent. It concerns a Windows 10 laptop and a Samsung S7 phone. When having both connected, but listening to the laptop, the headphones connected will sometimes play every few minutes and sometimes it will not. Haven't found a decent pattern yet on when this occurs...

    0
  • DU320604

    I have the same issue when connected to my iPhone 7 so I don't even use them which is really unfortunate because they were quite expensive.

    0
  • Metamyr

    OP Here. FWIW, my issue was resolved when I upgraded my HTC One M8 to a Google Pixel.

    0
  • HL147105

    Same problem here with an iPhone 7.

    0
  • tnhansel

    I'm also having the same issue with iPhone 7 ios 11.1, which rendered my headphones useless in quiet environment such as the office.

    0
  • jsks

    Just got some X3s for Christmas. When I have them paired to my iPhone 6s and MacBook Pro, this happens constantly. It sometimes results in the headphones eventually going dead somehow. They won't respond to any button presses. The only way to get them back alive is to plug them into a charger. They were at 60% when they died, so I know they didn't simply run out of juice.

     

    Is multipoint simply not possible with Jaybirds? Can they at least connect to one paired device and just refuse to connect to another unless I manually disconnect. Even that would be better than what I have now. I think these are probably going back to the store. :(

    0
  • Dem Gainz

    I can't get it to stop. Deleted it from my laptop which it loved to connect to while asleep. Worst headphones I have ever owned. Sad because I had the old freedoms and they were great. New ones never made it 6 hours, let alone the 8 hours they advertise. Tried all types of chargers / plugs / USB blocks / etc. since I paid $150 for headphones and now responsible for measuring amps to ensure their product works as advertised lol. Thanks but no thanks.

    0
  • SonOfRagnar

    Yup, just connected to one device and I hear this every 30-60 seconds. It was even doing it on a work call I took just now though it doesn't do it while music is playing. I like the headphones besides that but it is almost pushing me over the edge.

    0
  • Sambell

    I’m having this issue too. I’m only connected to iPhone 6 Plus.

    0

Please sign in to leave a comment.