Hissing, white noise and background static on X3's

Answered

Comments

10 comments

  • Engelbert

    Hi zharry,

     

    The Jaybird X3 is a bluetooth device that runs in a high frequency and a white noise can be heard if and only if you focus your hearing to it and there's no audio. This white noise is related to the Bluetooth signal going back and forth from the headset and audio source.

     

    In your case, this is not the normal behavior coz you can hear it very clearly when playing low audio or even if the headset is not playing audio and un-paired. I recommend that you contact our support team for assistance in replacing the unit since it's clear that the issue is hardware related and you can't enjoy the buds.

     

    You can reach them via Chat, Email or Phone at https://jaybirdsport.com/en-us/support.html#contact

     

    Hope this information helps.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • MatthiasJ
    I have the exact same issue. Did getting a new pair stop the issue or should I just return the x3 and use my x2's?
    0
    Comment actions Permalink
  • Arbeitsloeffel

    Just wanted to add that I bought two of them from a Media Markt shop in Germany, Potsdam and they BOTH had the exact same issue.

     

    You're getting a very bad reputation by seeling such obviously broken produkts!

    0
    Comment actions Permalink
  • Scott_M

    Just bought a set also and immediately noticed the white noise and i got a crack/click noise just before white noise started and after it stops. I have returned them for a replacement but the issue remains. Have tried pairing to 3 other devices and same noises occur. A friend whom bought his months ago and recommended them does not get this issue. This could be batch issue. Looking forward to hearing something from Jaybird. Can't fault the return/replacement but the product shouldn't behave like this.

    0
    Comment actions Permalink
  • Stan-in-London

    Just took delivery of X3 and constant hissing the left earbud, pairing problematic too. Spent months researching buds.... and never came across this issue re Jaybird, trying to contact support for a replacement product but what a let down, was really excited to get the product.

    0
    Comment actions Permalink
  • Cooperfist

    I bought 4 X3's last Xmas at the same Best Buy Store, long story short, 2 of them where noticeable having white noise, I guess a faulty batch, people at Best Buy replaced them no questions asked. Very happy with the earbuds, should have better quality control at the factory though.

     

    0
    Comment actions Permalink
  • Fieldsy
    I’m on my second pair of X3’s. First pair just stopped charging. Contacted support, tried the solutions and nothing worked. Splurged for another pair and they worked great for a couple of months. Now I’ve got hissing and white noise in the bud closest to the controller and it won’t stop. I tried all of the holding buttons, pressing 8 timed and hold, etc. nothing is working. Anyone have something else I can try before switching?
    0
    Comment actions Permalink
  • zharry

    Hey everyone!

     

    It's been a while since I first posted this, but with all the comments since then, I'd just like to share my experience.

     

    Much like what Jaybird_Egie said, it's a bluetooth device, so there is always gonna be a bit of hissing. After a while, it's almost unnoticeable and once you start exercising or go outside at all, you can't hear it at all.

     

    If your issue is just a bit of background/static buzz, it's not that big a deal. I tried swapping it for a new pair at the store, but you can still notice the white noise. The pair of Jaybird X3's that I've had for the past year-ish have been the best in terms of audio quality and ease of use out of many earbuds I've tried.

     

    However, if it's only occurring in one ear or there is another problem, definitely try contacting support/getting it swapped.

     

    Good luck everyone!

    0
    Comment actions Permalink
  • socalighost

    What I don't understand is why that background hiss is not present in the pair of Bluebuds X I have, but the X3s definitely have them. If the original Bluebuds X had this noise then I'd say it's definitely a bluetooth side effect, but they are virtually silent compared with the X3s.

    0
    Comment actions Permalink
  • jaydubs79

    If you do not use the app it will likely sorta solve the issue. I reset the X3's twice after reset there was only a slight hiss or connection chirps that I would often hear. Particularly out of the right bud. As soon as I used the app the hiss becomes much louder. I do not understand the issue. I have had many brands of bluetooth headsets including other Jaybirds. This is the first that this hiss has been an issue. it's as if there may be a bad internal connection, a dirty solder or something? The biggest problem is I do 90% of my listening in an office environment so my ear hears it and i notice it... always.

    0
    Comment actions Permalink

Please sign in to leave a comment.