I have found jaybird have a big flaw.

Comments

11 comments

  • Engelbert

    Hi carcaju,

     

    Thank you for sharing your thoughts and insights with the Jaybird X2 and Bluebuds X. Let me forward your post to the appropriate team here in Jaybird so that they can review the information that you have provided.

     

    With regards to your case, try a factory reset on the headset. I hope that this works and is not related to the "flaw" that you have mentioned.

     

    1. Turn headphones off.

    2. Put in Pairing mode by holding the middle button for 6-8 seconds until it says "Searching for your Music Device" and wait for the headset to flash red and green. 

    3. Do a reset by holding both volume buttons down 6-8 seconds and wait for the headset to flash orange 3 times. 

    4. Delete or "Forget" the headset profile from the Bluetooth list of the mobile device. 

    5. Put headphones back into pairing mode and connect them to your device. 

    6. Test the headset afterwards.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • carcaju

    found another problem. the volume control does not sync with the phone control.

    Jaybird is going backwards after got purchased by another company. I have to rethink the next time when I am looking for another pair.

    0
    Comment actions Permalink
  • carcaju

    First, stupid website. every time I try to login and it pump me invalid password even I double confirmed I didn't type it wrong.

    I did stupid reset and first time the volume are reversed, + means lower volume, - means higher volume. 

    Then there is no 3 flashes when I tried to do a factory reset. I hold them for at least 30 seconds, nothing happen.

     

    0
    Comment actions Permalink
  • Engelbert

    Hi carcaju,

     

    I strongly believe that the "haywire" behavior that you are experiencing with the Jaybird headset is hardware related. I recommend that you contact our support team via Chat, Email or Phone for further assistance at https://jaybirdsport.com/en-us/support.html#contact.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • Eve6er69
    I've noticed this issue with the x2 as well. This winter I was using the x2's and a mask to start using my snowblower and it barely had sound because of the right fit.
    0
    Comment actions Permalink
  • carcaju

    I have reset the X2 and reconnect to the phone and the volume still no sync with the phone. I have to click twice to turn on to the minimum volume to hear something from the phone volume control. But only with one click from the X2 up or down. 

    This is frustrating and the volume is loud even with the lowest setting.

    Hardware issue is for sure and keep doing the "magic factory reset" and re-pair is not going to work. sad.....

    0
    Comment actions Permalink
  • carcaju

    I am still have to change my password every time I try to login. and it is also sad.....

    0
    Comment actions Permalink
  • carcaju

    I have to take the title back. 

    I should say I have found jaybird have "multiple" big flaws.

    0
    Comment actions Permalink
  • carcaju

    I found more flaws, I have another white X2 and the reception is good but the new black X2 is very poor, sometime if I turn my head to one side and I will lost signal but not the white one. The black one is not good, they really need have good QA control. for the price we pay this is not acceptable. And almost no return policy after Logitech bought the company. sad.....

    0
    Comment actions Permalink
  • carcaju

    I have to reset my password to login again, such a good website. Where are the IT? Are they all taking a nap????

    0
    Comment actions Permalink
  • carcaju

    The best way to use it is go buy 5 pairs and try them out. Because Jaybird has poor customer service and no return. The only thing they will do is ask you to do a factory reset , that is it.

    0
    Comment actions Permalink

Please sign in to leave a comment.