IT KEEPS TURNING OFF BY ITSELF WHEN I TURN IT ON

Comments

13 comments

  • bbrac

    @Abigail Kerr 

     

    I am sorry to hear that, try this hard reset and see if that stops. 

     

    During the pairing mode ( red / green ) it is possible to reset your headphones. First follow the steps to enter pairing mode. By powering up the headset, holding past the ( green ) led light till you receive the multi color flashing.  Then instantly switch and hold the up & down key simultaneously until the dual color status indicator LED rapidly flashes 5 times and or a double high tone is heard threw the headset.

     

    You'll want to delete & repair the headset to your music player once finished with that.

     

    0
    Comment actions Permalink
  • Abigail209

    It worked for a bit. But they started doing it again. It's like i'm pushing down on the power button when i'm not. It's infuriating.

    0
    Comment actions Permalink
  • bbrac

    @Abigail Kerr Okay, I just created you a case and sent over an email to help you further. Just respond to that email for further communication.

    0
    Comment actions Permalink
  • Abigail209
    Good evening thank you for getting in contact with me. -Abigail kerr
    0
    Comment actions Permalink
  • Shake14

    I am getting the same issue and the reset only works for a short while. I've tried several times.

     

    Any help appreciated

    Paul

    0
    Comment actions Permalink
  • Ronald_MP

    I'm getting the same issue too! The reset just work for a day. Does anybody now what to do ?

    0
    Comment actions Permalink
  • Ronald_MP

    Abigail209 did you solve this problem ?

    0
    Comment actions Permalink
  • Shake14

    This problem is apparently due to the degradation of the battery. I complained to Jaybird and got new set of X3s. I would suggest you do the same.

    0
    Comment actions Permalink
  • Ronald_MP

    Thanks @Paul Stevens?  im just waiting for Jaybird to respond my emails.

    0
    Comment actions Permalink
  • sinduria1595
    Same problem with my jaybird X , please suggest how to solve this issue .
    0
    Comment actions Permalink
  • Jimester

    I have the same issue. It keeps turning on , pairing and turning off automatically. Can not use it at all.

    0
    Comment actions Permalink
  • Shake14

    To everyone getting this problem. It is a fault with the battery. Complain and Jaybird should replace free of charge. They did for me

    0
    Comment actions Permalink
  • Ricky1001

    @Paul Stevens?  Is your earphone still in warranty period?

    0
    Comment actions Permalink

Please sign in to leave a comment.