X2 used to work and all of sudden not able to pair

Comments

48 comments

  • bzainthemd

    What is worse, I called in today, waited for about 30 minutes on hold, for them to tell me that their "system was down" and they could not help me.  They told me to call again tomorrow morning as if I have all the time in the world to call and wait on hold.  I cannot believe how bad the customer service is with this company.  I would avoid these headphones like the plague if I were to buy again.

    0
    Comment actions Permalink
  • bbrac

    @Monica Houston I just created you another case. Please reply to that case for further help. 

    0
    Comment actions Permalink
  • bbrac

    @robert Marks Im sorry for your experience. I went ahead and responded to the case that you have created. Please respond to that email for further help. 

    0
    Comment actions Permalink
  • ernste

    Same here. No more connection, so headset is useless atm. Worst thing is, I have been trying to contact support since Nov 22, but even though 2 cases have been created, and I have provided all information asked for, I am still awaiting a response.

     

    This level of support is really unacceptable for a product in this price range.

    0
    Comment actions Permalink
  • bbrac

    @Ernst Eeldert I replied to that case that was set up for you. Please look at that email for further help. 

    0
    Comment actions Permalink
  • Jack Sensei

    I finally got a reply and they want me to cut the earphones in half and send a picture.  Then they will give me a refund?  Has anybody done this at all?

    0
    Comment actions Permalink
  • ernste
    Same here. Felt a bit weird/scary to do this, but the set is useless at this point anyway, so I went ahead. Fingers crossed :)
    0
    Comment actions Permalink
  • jodiz

    I'm having the same problem described in this thread, and have done all the trouble-shooting steps described as well.  This product must have some kind of defect,which affects its ability to pair.  This is unacceptable in a product this expensive. Planning to set up a "case" with support but am not hopeful.  I am going to let everyone I know not to buy this product because it is so unreliable.  jz

    0
    Comment actions Permalink
  • bzainthemd

    All, I should have posted this earlier.  Once customer service contacted me, I took the pictures they asked for, cut the X2's, and I received my new Freedoms a few days later.  The Freedoms have worked great so far.  I think once you get contacted by customer service you should be okay.  I just took a few days for them to get back to me, but once they did, it was fine.  Obviously, there is a problem with the X2's if this many people are having the same problem with them, but they were quick to send me the Freedoms.  Hope this helps.

    0
    Comment actions Permalink
  • sabi_sbb

    Same problem here. I contacted Support 11 days ago and have not heard back. My X2 just stopped connecting with my phone. I hope to hear from them if I'm commenting on some of these forums.

    0
    Comment actions Permalink
  • pandalee

    This problem has been happening for me too. Online chat hasn't been helpful so I'm going to try to reach out to customer service or support. Fingers crossed to get help! I feel the same way and hope to hear back or else I definitely wouldn't purchase again.

    0
    Comment actions Permalink
  • tjandera

    There is clearly an issue with the X2's as I'm having the same issue as well.  I started a similar thread and after getting them to pair initially, now I can't get them to pair again.  My phone will not detect.  Based on the fact that Jaybird is unwilling to acknowledge the issue and take action, I cannot and will not EVER buy another one of their products or recommend them to anyone.  JUNK 

    0
    Comment actions Permalink
  • mikeike32

    I have had the same exact issue. Can't reset the earbuds or anything and when I charge it, it only powers on, then proceeds to do absolutely nothing.

    0
    Comment actions Permalink
  • Shazamm
    I have the same problem. Had my x2 for a month now and it just stopped working out of nowhere. Can't discover my device, won't stay paired, sometimes it turns off on its own.... It's so frustrating.
    0
    Comment actions Permalink
  • Kylebara
    I've been having the same issue. It was working fine a couple of weeks ago and suddenly stopped connecting to any device. I have tried all of the things listed here and still no luck
    0
    Comment actions Permalink
  • Griff25
    When my set had the issue of pairing I went on to my phone (iPhone) Bluetooth settings, clicked the jaybirds and forget this device. Then started again with the pairing and it connected fine. The only time I get the pairing issue is if I have turned my phones Bluetooth off while the head phones where still connected. But the above fixes the pairing for me. Hope this helps.
    0
    Comment actions Permalink
  • Darrien28

    Hi all,

     

    My X2s were working great! I have 2 iphones, a macbook air, and a samsung tablet. It pairs and then connects seamlessly - or it did until a couple weeks back.

     

    I did as suggested. I forgot from the iphone 7 plus, and tried to repair and connect...nada. Hard reset. But dont get the three flashes of amber light...just goes black.

     

    Tried on iphone 6 plus - old phone - and it worked ok. Yay! Tried to “forget” it on the 6’plus, and while it would pair again, it would not connect.

     

    Same deal with macbook air - AND with samsung galaxy tab. Worked ok - until i forgot and tried to repair/connect.

     

    Raised a ticket online by email - and went through all the trouble shooting they (Rachel) asked me to. It was then referred to the asia pacific guys to help me (Robbie), and they sent me trouble-shooting stuff for the wrong model of ear buds (just copy n pasted by the looks - it was for the x3/x4 model!) and then told me my ear buds are out of warranty, so let them know if i wanted a discount on a new set.

     

    ...seriously?

     

    I get that theyre out of warranty - but it seems like theres a firmware glitch or something? It doesnt appear physical.

     

    Plus, I’d given the first rep, Rachel, the purchase date etc - so why go through all that trouble shooting if it was never going to be upheld anyway??

     

    Just seems like lipservice to me. And a high end set of buds should last more than two years! My SHURE SE215s are still going strong 8 years on - so i think ill stick a few hundred bucks into getting the wireless versions of the SHUREs and these guys can stick their discounts..... for the record, SHURE ear buds are sweat resistant too - and i wore mine at the gym for years everyday - nonill effects. Only went to jaybird cause i wanted wireless... now that SHURE do wireless and jaybird are not coming to the party....... its a no-brainer.

    0
    Comment actions Permalink
  • Christian Dominguez

    Same issue here. I wonder why Jaybird is not addressing this?

    0
    Comment actions Permalink

Please sign in to leave a comment.