My Jaybird Freedom Sprint have stopped charging.

Comments

5 comments

  • Engelbert

    Hi @Kevin Dillow ,

     

    I'm sorry to hear that your Freedom Sprint does not charge and won't power ON unless plugged in to charge.

     

    Please try a factory reset that can help you resolve the issue with the headset.

     

    1. Turn OFF the headset and plug it to a power source.

    2. Hold the power and volume up buttons at the same time for 8 seconds.

    3. Once the headset turns ON, unplug it from the power and source, turn it OFF by holding down the power button for 8 seconds then charge it normally for 2.5 hours.

     

    Hope this helps.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • FLKED
    I’m sorry to say that this did not resolve my issue. Any other suggestions?
    0
    Comment actions Permalink
  • liorsh

    i just had the same problam and i tried to follow the instructions, unfortunately nothing happen. Is there any other suggestion?

    0
    Comment actions Permalink
  • Notgreg
    I ran into the same problem. My headphones stop charging and then a few days later I left it on the charger and found it with the battery exploded. Not like a big bang explosion the battery just spewed out the internal assets and dried up on the charger. And now I can't find the receipt to try to take it in. It would seem the internal battery on the headphones are flawed and have a tendency to malfunction. I bought these things with the direct expectation that I would not run into this problem. I've gone through three 200+ dollar headphones and l they all died on me. The batteries just can't seem to handle perspiration. Doesn't matter how much you pay its all the same "crap quality".
    0
    Comment actions Permalink
  • geebe

    Just tried the reset function and guess what --junk crap--

    0
    Comment actions Permalink

Please sign in to leave a comment.