How to reset the Freedom 3?

Comments

3 comments

  • Engelbert

    Hi ReinerS10,

     

    I'm sad to hear that your Freedom 3 is not working properly. I'll be glad to help you with the concern.

     

    The Freedom 3 does not have a factory reset, however, you can do an 8 button process that can help resolve the issue.

     

    1. Firmly but quickly press the power button 8 times and then hold for 5 seconds. Repeat 2 times.

    2. When finished, plug the headset into the charger for 2.5 hours and check the color of the LED status lights.

    3. Power ON the device by holding the power button for 10 seconds or more.

     

    NOTE: Most of the time if the headset turns RED, it will charge and function normally again. Make sure to fully charge the headset when the light is red.

     

    Warm regards,

    Egie

    0
    Comment actions Permalink
  • ReinerS10
    Hi Egie, Your solution worked great. Power on/off, connection, play/pause all working great. The only thing not working is the Vol +/- and Fwd/Rwd is not working at all. Do you have a solution for that issue? On another topic, I can no longer sign into my account. When I try to reset my password, the link in the email sends me back to the signon page, no password reset option. Any ideas? Thank you, Reiner Schmidt Sent from my Mobile Device
    0
    Comment actions Permalink
  • ReinerS10

    {finally got my password issue fixed}

     

    Well, I thought everything was working fine (except the Vol buttons). But it only worked for a day. Did the 8 button process again but only works the one time. Any other ideas? I would hate to loose this headset!

    0
    Comment actions Permalink

Please sign in to leave a comment.