Hi there. I have a pair of X3s which have worked perfectly , but recently I have found that they no longer hold their charge. Unfortunately, they are over a year old, so no longer under warranty. Is there a way to replace the battery?

Answered

Comments

5 comments

  • Logi_Bruce

    Hi Jimboot,

     

    I am sorry to hear that your Jaybird X3 do not hold a charge. I can assure that this is not the behavior and performance expected from the product. Please try these suggestions that can help to resolve the issue of your headset:

     

    - Computers are the best and safest method, as is anything 1 AMP or less.

    - Try a different power source/charger

    - Car chargers produce a much greater power supply and should be avoided.

    - Over-charging the battery will quickly reduce the life of the headphones, so in addition to monitoring the power supply, limit the charge time to 2.5 hours,

    - To get the most out of your battery it is recommended to charge the buds when the low battery status is indicated.

    - Avoid charging your headphones after exposure to sweat.

    - Make sure charging port/cradle is clear of any debris.

     

    Feel free to reach back to us by replying to this post or contacting our other support channels at https://www.jaybirdsport.com/en-us/support.html

     

    Warm Regards,

    Jaybird_Bruce

    Jaybird Customer Experience

    #PowerYourPassion

    0
    Comment actions Permalink
  • Jimboot

    Many thanks for the reply. I have tried your recommendations and unfortunately they haven't helped. Do you know if the battery is replaceable, as I believe this may be issue?

    0
    Comment actions Permalink
  • Arual95

    Having the same problem. It's a pity, that such expensive earphones and such a poor support service. Exactly the same message was written to many other people without any obvious help. What I see in this answer is "well, it's not that our product is a peace of crap, it's you that failed to use it correctly, so it's your problem now". Awesome.

    0
    Comment actions Permalink
  • DamianTay

    I am also having the same issues. In fact the X3 looses charge even when it is turned off. Quite frustrating and disappointing. Only had the X3 for close to a year?

    0
    Comment actions Permalink
  • Jimboot

    Yes, looking further into it, it seems like a known issue, which they give a generic reply to. I'll have to write this one to an expensive lesson.

    0
    Comment actions Permalink

Please sign in to leave a comment.