My Jay X3 will not turn on anymore.

Answered

Comments

5 comments

  • bbrac

    @max keomanivong I will send the reset info below. Please let me know if that helps. 

     

    To reset your X3 buds to their original factory settings, put your buds in pairing mode by turning the buds off then push and hold the center button for more than 4 seconds until you see alternating red/green LED. 

     

    While the LEDs are flashing red/green double tap the center button. Upon successful party reset, the LED turns orange and your buds turn off. 

     

    NOTE: Once your buds have been reset and you power on they will automatically go into paring mode. Select “Forget” or “Remove” X3 from your device’s bluetooth menu and pair again.

    0
    Comment actions Permalink
  • 8bit_dab

    it doesnt turn on tho.... even when i plug it in a power supply.

    0
    Comment actions Permalink
  • 8bit_dab

    and i already tried your suggestion. doesnt work.

    0
    Comment actions Permalink
  • 8bit_dab
    it didnt work. i plugged it in the usb charger. and no light on the led is showing up. i cant "hard reset" it even when i did the 4 seconds power button while it off. it doesnt turn on, doesnt charge, doesnt anything. just happened this morning before leaving to work. I had this about 4 weeks ago from best buy.
    0
    Comment actions Permalink
  • bbrac

    @max keomanivong This is covered by our warranty. If that did not work please send an email, chat or call into the link below so that one of our Agents can help you with a warranty claim. 

     

    http://www.jaybirdsport.com/support/

    0
    Comment actions Permalink

Please sign in to leave a comment.